Wi-Fi & connectivity

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Am92
Level 7

[OS 10.5] Express device connectivity issue

Model: 3930X - Roku Express
Serial Number: X00400E0VEP2
Software Version: 10.5.0 build 4191-AE
this device won’t even connect to WiFi anymore even though the signal strength is excellent. I’ve restarted multiple times. Restarted the router multiple times. And even factory reset it. And it still won’t connect 

My other device is:
Model: 3930X Roku Express
Serial Number: X00400S7DJAX
software: 10.0.0 build 4209-AE
this one will connect to internet but picture is blurry and it stops to buffer every few minutes  

both devices quit working 10/20/21  

0 Kudos
46 REPLIES 46
RokuDanny-R
Roku Employee
Roku Employee

Re: Performance Issues Since 10.5 Upgrade

@Am92

Thanks for the follow up post and providing us with your information.

I have passed the information along to the appropriate Roku team to investigate further.

In the meantime, can you please let us know who is your ISP (internet service provider) and what kind of router are you using?

Please keep us posted.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
melanie0989
Level 7

Roku still will not connect to internet even after factory reset

Model 39330x-roku express

serial number: X0040004YTPN (S00829A4YTPN)

  ID PN-240-452 

I have done the factory reset based on other post advice but it still cannot find or connect to our Wi-Fi. All other devices working on the Wi-Fi just fine. I've also tried turning everything off again and on again changing channels etc absolutely nothing is working. 

makaiguy
Community Streaming Expert

Re: Roku still will not connect to internet even after factory reset

@melanie0989-

There are a couple of network connection problems recently being reported that have been caused by updates to routers. These have primarily been reported with routers supplied by internet providers, but it's possible they could also occur with user-owned routers that have received updates.

    • ROKU LOCATES NETWORK BUT CANNOT CONNECT
      Some router updates (reported for Xfinity and Cox but there could be others) have changed the router's security setting from b/g/n to just g/n, causing some Roku models to lose their ability to connect to the network. The solution is to set the router's configuration back to using b/g/n security.
    • ROKU CANNOT FIND LOCAL WIFI NETWORK
      Some routers have had their 2.4 GHz wifi band turned off, leaving only the 5 GHz band operational. Devices with single band wifi radios, notably Roku Express and Premiere models (but not Express 4K models) as well as many other single band devices can not even see the 5 GHz band. The solution is to reconfigure the router and turn the 2.4 GHz band back on.

      If this problem was not caused by a router update deactivating the 2.4 GHz band, often a restart of the router (even if other devices are still connecting) followed by a restart of the Roku via Settings > System > System restart (for Roku TV it's Settings > System > Power > Restart) will allow the connection to be reestablished.

If you need to make configuration changes on equipment supplied by your internet provider but you have no access to its settings, you may need to request your internet provider to make the changes for you.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X
Jette75
Level 7

Re: OS 10.5 device connectivity issue

I am also having the same issue. My Roku won't connect at all, even after a factory reset. 

Model 393OX

SN 500820ACSRT7

I have Cox as my ISP

0 Kudos
renojim
Community Streaming Expert

Re: OS 10.5 device connectivity issue

@Jette75, go into your router's settings and change the wireless mode from g/n to b/g/n.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
Jette75
Level 7

Re: OS 10.5 device connectivity issue

Holy **bleep**! It worked! So far so good! Thank you very much

0 Kudos
Am92
Level 7

Re: Performance Issues Since 10.5 Upgrade

My provider is Comcast.  They replaced the modem so that is brand new.  

0 Kudos
renojim
Community Streaming Expert

Re: Performance Issues Since 10.5 Upgrade

@Am92, did you change, or have Comcast change, the wireless mode to b/g/n?

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
BarnzSays
Level 7

Upgraded to T-Mobile Home Internet. Our 3930X Express drops wifi after <10 seconds.

Seen the Hulu T-Vision posts. Our issue is different I think. After bring to new gateway/router up our both of our Roku Express boxes report a good signal and +10 Mb speed. Leaving the Network screen to Home and most times the time displayed goes before leaving the Netw.ork screen. Updated every thing. On a 2.4 Ghz channel that a little crowded but sure thats not going to be the issue. Have HULU but not the live TV one. Anybody else have this kind of issue? Have an Android TV that works fine. Work around using my cell hotspot, on T-Mobile LTE coincidently, drives our two Roku fine. Head scratcher????

0 Kudos