Wi-Fi & connectivity

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Michigan2021
Level 7

No longer able to connect to WFi on either Roku device. All other devices in my home will connect.

I have been able to connect until about the last month or so. I even factory reset one of my players. No change. Wifi works with every other device in my home. I’ve been a Roku customer for years. This is very disappointing, and even more so as it seems there is no support available. I work in IT, and have literally helped hundreds of folks with internet connection issues. My connection is excellent, but the Roku players just won’t connect anymore. What can be done?

15 REPLIES 15
AvsGunnar
Community Streaming Expert

Re: No longer able to connect to WFi on either Roku device. All other devices in my home will connec

@Michigan2021 

Verify that your 2.4ghz band is Enabled/On, SSID is broadcasting, Channel between 1 and 11, Mode/Protocol set to b/g/n, and channel width/bandwidth is 20mhz.

The Mode/Protocol setting is currently affecting Xfinity, Comcast, and Cox ISP managed routers, so verify all three protocols are enabled. (b/g/n, not merely g/n)

For the 5ghz band, verify that you are not using a DFS channel (52-140).  If currently set to Auto, try using 36-48 or 149-161 and lowering your channel width/bandwidth.

Additionally, try using an open network (disable SSID password) and see if you can connect.  If you can, try using a simpler password when re-enabling password. 

If you are using a merged network, could be that your 5ghz is using DFS, preventing 5ghz band connection, and then device is trying to connect to your 2.4ghz band, but cannot because of the b/g/n scenario.

Restart both router and Roku device after applying and saving changes.

Feel free to post back with router model number and ISP and network details (configurations from above suggestions) if still having issues.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
JustDeb7
Level 8

Re: No longer able to connect to WFi on either Roku device. All other devices in my home will connec

In regards to your advice:  "Verify that your 2.4ghz band is Enabled/On, SSID is broadcasting, Channel between 1 and 11, Mode/Protocol set to b/g/n, and channel width/bandwidth is 20mhz.

The Mode/Protocol setting is currently affecting Xfinity, Comcast, and Cox ISP managed routers, so verify all three protocols are enabled. (b/g/n, not merely g/n)"

 

How do I check all of this ?  I have Xfinity and am located in Florida if that makes a difference !  I watched tv fine yesterday before work but when i got home last night I couldn't connect with my Roku, although my Daughter could connect to her tv with her Firestick and I can connect to my laptop just fine ! 

0 Kudos
JustDeb7
Level 8

Re: No longer able to connect to WFi on either Roku device. All other devices in my home will connec

I am having the same issue...have restarted both the Modem and Roku at least 5 times and still cannot connect ! Keeps saying I am not connected to the internet, but every other device in the house connects just fine !  It is so annoying !! 

0 Kudos
AvsGunnar
Community Streaming Expert

Re: No longer able to connect to WFi on either Roku device. All other devices in my home will connec

@JustDeb7 

[Reposted from https://community.roku.com/t5/Network-Wireless-Wired-Connections/Roku-Express-suddenly-will-not-conn...]

-----

Basically, all you really have to do is verify that your 2.4ghz wi-fi band is enabled and broadcasting, and that you switch your 2.4ghz band Mode/protocol to b/g/n.

Either launch your Xfinity app or type in 10.0.0.1 in a web browser that is connected to the same network as your router.  Your Username = admin, and your Password = password.

Then look on left of Screen for Gateway selection.  From there click/navigate to Gateway...Connection...Wifi.  Then select Edit on your 2.4ghz Frequency Band.  From there a screen should appear with various Wireless Configuration Settings.  This is the screen where you will need to verify that your 2.4ghz band is Enabled and the 2.4ghz SSID (network name) is Broadcasting, and where you switch your Mode from g/n to b/g/n.  After verifying and making changes, press SAVE SETTINGS, and then restart both your router and your Roku device.

You really should be good to go from there.

Feel free to post back with an update or if you need more help.

Click images to enlarge

xfinity bgn_1.pngxfinity bgn_2.pngxfinity bgn_3.pngxfinity bgn_4.png

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941

Re: No longer able to connect to WFi on either Roku device. All other devices in my home will connec

Tried the above solutions but cannot login to admin

0 Kudos
AvsGunnar
Community Streaming Expert

Re: No longer able to connect to WFi on either Roku device. All other devices in my home will connec

@Gracefulmomma 

You can try using the mobile app for you ISP (if applicable).  Otherwise, in the Roku under Settings..Network..About is your IP address and your Gateway showing up in the form of 10.0.0.x ?

What exactly is the issue you are having regarding logging into the admin?  

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos

Re: No longer able to connect to WFi on either Roku device. All other devices in my home will connec

Nothing is showing up under "About".

It tells me the password is incorrect.

0 Kudos

Re: not sure how to reply

I got your private message and tried to reply but I'm not sure how to send a private message.

0 Kudos
AvsGunnar
Community Streaming Expert

Re: not sure how to reply

@Gracefulmomma 

In order to reply to anyone's Private Message, just click on the attn/title of the message (not the message text itself), it shold bring up a seperate window with full message.  After the message you should be presented with a Reply button.

To create a Private Message you can just click on a user's name and should be presented an option to send private message.

----

Regarding your issue, for the first part of this, go to your Roku device and using the remote, look at Settings..Network...About [press ok or use right arrow].

Should see on right side of screen your IP address and Gateway.

Should look like 10.0.0.x or 192.168.0.x or 192.168.1.x

This determines how to login to the router admin which we can address later.  Both the IP address and your Gateway should look very similar, except the "x" will be different. (referred to as the last octet)

Also, please find the model number of your router (sticker on bottom or side of router) and who is your ISP (internet service provider)?

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos