Wi-Fi & connectivity

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
SteveAmm
Level 7

Microwave problems with connections

My Premier+ unit loses connection every time the microwave turns on. When the Microwave turns off the connection is restored. Is there anything that I could do to stop this?

0 Kudos
4 REPLIES 4
andyross
Level 16

Re: Microwave problems with connections

You are probably connected using the 2.4GHz WiFi band. Microwave ovens use nearly the same frequency. That is because it is an 'open' frequency that can be used for many purposes.

I think the Premiere+ supports 5GHz. On many routers and gateways, you can set a separate SSID (WiFi network name) for the 2.4GHz and 5GHz bands. That way, you can force devices to a particular band.

Strega
Level 17

Re: Microwave problems with connections

It might also help to move/reorient the affected devices.  Ie: try not to have either the Roku or the router near the microwave and don’t have the microwave near to being in-line between them.

Microwaves generate vastly more RF than Wi-Fi but they're supposed to keep it bottled up.  But sometimes a little gets out especially if there was been a lot of wear and tear around the door.

MilesT
Level 14

Re: Microwave problems with connections

If the microwave is "leaking" enough to knock out the roku WiFi signal, I would suggest that you buy a new microwave as they are not supposed to leak that much!

Also, put the TV/Roku on a surge suppressing power strip, that might help.  Long shot: buy a clip on RF choke from an electronic supply place and route the roku cable through that (round cylinder thing). Should not be expensive.

 

Not a Roku employee
0 Kudos
AvsGunnar
Community Streaming Expert

Re: Microwave problems with connections

@SteveAmm 

The older Roku Premiere/Premiere+ (4620/4630) are dual band capable (2.4ghz and 5ghz).  The newer Roku Premiere/Premiere+ (3920/3921) are only 2.4ghz capable (b/g/n).

Since microwaves apparently operate at about 2.45 ghz, it is often suggested to try manually assigning your wireless channel within your router to Channel 1 (2.412 ghz) or Channel 6 (2.437 ghz) in order to "avoid" the interference caused by the microwave, rather than set to "Auto", if relocating either the microwave, the router, or the device (Roku) is impractical.

You may have to try a few channels in between 1 and 6, but if channel 1 works for you, I would keep it there.  Additionally, I would lower the Channel Width/Bandwidth to 20mhz in your router settings as well to help minimize interference/noise.

Here is a pretty simple article explaining the microwave conundrum and shows you the 2.4ghz spectrum. (https://www.howtogeek.com/171869/why-does-running-my-microwave-kill-my-wi-fi-connectivity/)

Feel free to post back with an update or if you need help making these changes at your router.  Post back with Roku model number, router model number, and ISP. (internet provider)

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos