Wi-Fi & connectivity

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jjones2424
Level 7

Certain Apps Keep Losing Connection on Roku Express HD Streaming Media Player

I have had this device for almost 2 years and in the last few months the Bravo Channel and Fox Sports Channel keep losing connectivity and take me back to the Home Screen while I'm watching a program. Netflix and Fix News Apps don't seem to have an issue. I have two of these media players and both behave the same way. Maybe TCL Roku TVs don't have this problem. I've uninstalled the channels and reinstalled. Doesn't help. I've rebooted the Roku and that doesn't help either. What should I do?

0 Kudos
4 REPLIES 4
makaiguy
Community Streaming Expert

Re: Certain Apps Keep Losing Connection on Roku Express HD Streaming Media Player

@jjones2424-

After removing a channel, best practice is to clear the Roku's memory by restarting it  before reinstalling the channel.   Did you do this?  Without the restart you may not get a clean reinstall. 

Depending on your Roku model and Roku version number you'll find the System restart option under either Settings > System or Settings > System > Power... or just unplug from its power source for a few seconds then plug back in.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X
0 Kudos
jjones2424
Level 7

Re: Certain Apps Keep Losing Connection on Roku Express HD Streaming Media Player

I followed your steps by removing the channel, restarting the Roku to clear the memory and reinstalling the channel. The problem still is happening. A few things I was to mention specifically about the Bravo Channel;

1. When I reinstalled the channel after the restart it had my TV provider in it's memory. Therefore I didn't have to sign in from scratch which I though was odd if a restart was supposed to "clear" the memory.

2. When Bravo channel starts acting it, the video on the screen says "No Internet Connection.. Retry or Go to Setup" HOWEVER the audio of the programming still plays! If I press the back arrow on my remote to take me out of the show and it shows the video for a hot second and then takes me out to the channel main menu.

3. Bravo channel works fine on my 2 TCL Roku TVs. It misbehaves on my Media Players.

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: Certain Apps Keep Losing Connection on Roku Express HD Streaming Media Player

@jjones2424

Thanks for the posts.

If you are unable to resolve the issue, can you please provide us the following information:
-Roku device model, serial number, device ID, and software OS/version (these can all be found in Settings > System > About)
-does this issue occur on a specific channel? if so, what channel and what version/build is the channel (this can be found be selecting the channel on the Home screen and pressing the * button)
-tracker ID when this issue occurs (when you see this issue occur, press the Home button 5 times, followed by the Back button 5 times)
-steps to reproduce the issue you are seeing

Once we have this information, we will be able to look further into the issue for you.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
jjones2424
Level 7

Re: Certain Apps Keep Losing Connection on Roku Express HD Streaming Media Player

Danny -

Thank you for your help! I've gathered all of the information you've requested below.

Roku Device Information:

Roku #1

Model: 3930X - Roku Express

Serial Number: X00400JYG20E

Software Version: 10.0.0 build 4209-AE

Device ID: S00829AYG20E

Roku #2:

Model: 3930X - Roku Express

Serial Number: X00400627TXE

Software Version: 10.0.0 build 4209-AE

Device ID: S00829927TXE

Both devices above behave similarly with the issues. My two TCL Roku TVs do not have this issue on the channels that I have reported below with issues. Both Roku Express devices and both TCL Roku TVs are in close proximity to the WIFI router in my house.

So far, I've experienced problems on these channels below. However, the worst out of all three is the Bravo Channel as I can only watch programming on that channel for about a minute at a time before it stops working.

Bravo: Version 7.24 build 0

This is the worst channel. Within one minute of watching a program, the screen will go black and produce a message stating "No Internet Connection" however the audio of the program will still play. The only way out of the screen is to hit the home button or go to the back arrow to navigate back to the program and play it again. There doesn't appear to be a problem with the internet when you go back to play the program again. 

Fox Sports: Version 3.43 build 16077

This channel will just stop playing the program and take you back the the channel's home screen at random times.

Espn: Version 4.0 build 2021101900

This channel will just stop playing the program and take you back the the channel's home screen at random times.

To reproduce the issue, I went to the Bravo Channel and started to play a program. In one minute, the issue happened and the screen went black with a message suggesting that there is no Internet connection altough the audio of the program is playing just fine. 

I went ahead and pressed the home button 5 times and the back arrow 5 times to launch the Issue Tracker as you suggested.  This is was it reported:

Model: 3930X - Roku Express

Serial Number: X00400JYG20E (S00829AYG20E)

Software Version: 10.0.0 build 4209-AE

Timestamp: 2021-11-15T00:14:02Z

Please use the issue ID 0E-457-934 to report the current issue.

I went back to Bravo again to play the program, and within one minute the issue happened again.

Issue Tracker reported: ID 0E-457-937

Please let me know what you find out. I have owned these units for just under 2 years.

0 Kudos