Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

playback has stopped due to multiple playback errors in PLEX

Wondering if anyone has encountered this error in Plex? When playing a TV show file, I get an error message that states "playback has stopped due to multiple playback errors". Movie files play fine. And all the files work fine on an Amazon Fire stick in the Plex app. This seems very specific to the Plex app onplex, roku, error, playback Roku!

Tags (4)
0 Kudos
Community Moderator
Community Moderator

Re: playback has stopped due to multiple playback errors in PLEX

Hi @mydoghunter,

We thank you for taking your first post here in the Roku Community!

Does the issue only occur on Plex or across other channels installed on your Roku device? When did you start seeing this?

On the other hand, have you tried to remove the affected channel and then re-install it? If you haven't tried yet, to ensure the process is successful, restart your device before adding the channel back in. We recommend doing this from the Settings menu by navigating to Settings > System > Power (If you do not see a Power submenu, skip to the next step.) > System restart.

Please keep us posted on how it works.

All the best,


Jecheal R.
Roku Community Moderator
0 Kudos

Re: playback has stopped due to multiple playback errors in PLEX

Hi @RokuJechealR ,

Thanks for the quick response. I have one TV with the Roku Streaming Stick, and another TV with Amazon Firestick. Yesterday, on the Roku TV, I went to access the Plex channel(as I normally do) to view a video file categorized as a TV show. This is when I got the error, and it would bump back to the menu screen in Plex.


To do some troubleshooting, I tried a "movie" file the exact same way, and it worked without issue. I then tried the same "TV" file on my other TV with Firestick, and it worked fine, so I determined it was not a corrupt file.

I then uninstalled, then re-installed the Plex channel on the Roku stick and unplugged the Streaming stick, and plugged it back in a few minutes later. No dice!

Finally, I found an option in Plex to "optimize database". I tried this and re-scanned my libraries. This seems to have worked!!! So, maybe it wasn't fully a Roku issue after all. Strange that the Plex channel didn't have any issues on the Amazon firestick.

Anyhow, hope this helps if it happens to anyone else!

0 Kudos