Solving playback issues

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
AMD64
Level 7

Buffering and other issues

I have two Roku TVs and one Roku Express. I am having the same issues on all three. One TV is connected to the Internet via Ethernet and get 89 Mbps down which is excellent given that the Ethernet adapter is 100. The second TV is connected wirelessly and only gets 16 or 17 down which is poor given it is connected to a 5 Ghz network. The Roku Express is also connected wireless but gets 48 Mbps down which is excellent given it is connected to a 2.4 Ghz network.

I have a brand-new modem from the ISP and a new Wi-Fi 6 router. The modem is in bridge mode and the router is in router mode with a static IP. I have 500 Mbps down Internet. I have no other issues with my Internet. I own my own business and regularly have to do remote support, often on multiple systems at the same time, and with no issues. I also just download a 4.7 GB ISO in under 5 minutes. I called my ISP (Comcast) to verify that there were no issues on that end for these issues, they say there are none.

The issues I am having occur both with live TV and on demand. When watch live TV or on demand it may start right away or it may buffer for a while first. After buffering it may go back to the main menu (live TV) or the episode menu when watching on demand. When watching on demand it may buffer for a long time and start the episode over again no matter where at in the episode I had progressed too. What seems weird to me is that the commercials usually play with no issues, although on a rare occasion they will freeze. I do not experience these same issues or any issues with other streaming services. I am also able to watch YouTube or Facebook videos with no issues.

I have tried go back to the main menu (input or app selection) I have also tried restarting the TVs. Both have been hit and miss whether they work or not, but even if it works to get the program to play it is inevitable that the issues return.

Anybody have any ideas? Thank You

0 Kudos
2 REPLIES 2
RokuDanny-R
Roku Employee
Roku Employee

Re: Buffering and other issues

@AMD64

Thanks for the post.

Have you already tried changing the wireless channel of your wireless network to see if that helps resolve the issue you are experiencing?

For troubleshooting purposes, have you tried connecting your Roku devices to another wireless network, such as a mobile hotspot, to see if you are seeing the same issue occur?

Please keep us posted what you find out and we will be able to assist you further.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
AMD64
Level 7

Re: Buffering and other issues

What ever the issue is/was, was affecting both ethernet wired and wireless device.

I said is/was, because I have demoted the router to access point only and am currently using an old PC as a router. I have not had issues, or at least not to the level I was since.

0 Kudos