Solving playback issues

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Hapus
Level 8

Re: All sound, no picture

Jump to solution

Hello,

We are connecting our Roku directly to the TV and there are no other devices or peripherals.

 

Thank you,

0 Kudos
ih8aloss
Level 7

Re: All sound, no picture

Jump to solution

TLC @ROKU SUCKS! Worse POS I think I ever bought. Never buying another one again. Sound only no picture. Called Roku and even then they couldn't help. Said call TLC. Don't waste your money on this POS or your time trying to do their suggested fixes. It's a generic problem having that many common issues. 

 

0 Kudos
Shady58
Level 7

Re: All sound, no picture

Jump to solution

Try unplugging tv from wall and wait 1 minute (no sooner) and plug it back in.  It worked for me

0 Kudos
MrsDowns24
Level 7

Re: All sound, no picture

Jump to solution

Same thing happens to me! I’ve been running my Roku through my sound bar with no problems for years then one day no video! I’ve tried everything to fix it and the only thing that works is to directly plug in my Roku to my TV. I miss my sound bar….

Mikicmikido
Level 7

Re: All sound, no picture

Jump to solution

Same situation here. Totally fine for a year, now only audio (besides the home screen and channel menus). All subtitles and ad notifications (ie: Ad 1 of 2) also are shown on a black screen. Is there really no fix? I didn't really want to get a firestick, but sounds like roku has a problem.

0 Kudos
sbauer13
Level 8

Re: All sound, no picture

Jump to solution

I posted to this thread about 6 months ago when I got a new Roku 4K Express + and started having this "blackout" problem. I posted my problem as well as several others who were having the same problem and

RokuDanny-R
Roku Employee RokuDanny-R asked several questions about my setup which I [we] responded to but a solution was never given. It was only happening intermittently for me at that time but now it happens every day. 
 
 
I did try changing HDMI cables since that's where the problem seems to be occurring. I got new 8K HDR cables from Amazon. The blackout problem has stopped [for the last week or so] but now I get the problem where the resolution changes from Auto Detect to only 720. I can again fix this by going to Roku Settings>Display Type and selecting Auto Detect, even though it is already set for Auto Detect, then confirming the setting. It seems to be just another variation of the same problem. I've tried several cables and can't get the problem fixed.
 

As I and others have said, it's really a hassle to have to do this "fix" every time I want to watch TV with 4K resolution as this Roku was promised to deliver.
 
It would be nice if someone from Roku could suggest a solution or offer to replace the Roku itself.
 
 
 
 
 
0 Kudos
Belinda3
Level 7

Re: All sound, no picture

Jump to solution

I have unplugged my tv and let it be off for hours. Power on still no pic. I have done the factory reset several times with no change. I replaced the motherboard, t-con, and icon (?) boards. Plugged the tv in and still no pic. Called Hisense and they ran me through the reset and restart steps. Still no pic. The tv is less than 2 years old. I even tried a different power plug in. Still nothing. I feel like a tv repairman. Lol. Please help.

0 Kudos
RokuKariza-D
Roku Employee
Roku Employee

Re: All sound, no picture

Jump to solution

Hi @Belinda3

Thanks for posting here in the Community!

For clarification, does the no picture issue happens when you open a channel or once you start turning on your Roku device? Are you able to see the Roku home screen? Please let us know as well if you are experiencing the problem on a Roku TV. 

With more information, we can assist you further.


All the best,
Kariza

Kariza D.
Roku Forum Moderator
0 Kudos
Pulsar02
Level 7

Re: All sound, no picture

Jump to solution

I have the same issue, happens a lot, but not always. Roku (ultra) starts up fine, menu and apps work but as soon as I start playback i only get audio and the display is black. 
Changing the resolution to something else and then back to Auto (it detects 4k 60hz HDR) fixes the issue.

Would be great to get a permanent solution, this resolution switching hack is very irritating.

RokuDanny-R
Roku Employee
Roku Employee

Re: All sound, no picture

Jump to solution

@Pulsar02

Thanks for the post.

Does this issue occur on a specific channel or does it happen across all channels. If you set your resolution not to Auto, do you see the same issue occur?

Please keep us posted what you find out and we will be able to assist you further.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos