Solving playback issues

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
gottcent
Level 7

After 3 Months OK, Blank Screen

My Roku Express 4K (Model 3940X, S/N S07R514H11RX) was purchased in August and worked OK for 3 months. But now it produces blank screen with "Incompatible Video Signal" message. Tried rebooting (unplugging/replacing all cords), using different TV HDMI ports, clearing cache, resetting input to 720,  removing/replacing remote batteries. These occasionally result in home screen that leads to successful streaming, but the next time I turn off the unit and TV and later turn them on again, same problem. Will appreciate any help.

4 REPLIES 4
Pauliec
Level 7

Re: After 3 Months OK, Blank Screen

Have you found any resolution?  Having the same experience with a Roku just purchased and installed. 

0 Kudos
renojim
Community Streaming Expert

Re: After 3 Months OK, Blank Screen

@Pauliec, if you have a black screen after the Roku has been idle for 20+ minutes try pressing Home on the remote a few times and give it a few seconds to wake up.  You can also try disabling "power saving" under Settings->System->Power.

If you mean you never get anything other than a black screen even after you unplug the power and plug it back in then that's a different matter.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
Pauliec
Level 7

Re: After 3 Months OK, Blank Screen

No this is different. Wen through set up fine and had it playing as expected. When I turn off the tv and come back to it later I get a invalid signal error. Sometimes restarting the Roku works other times the sound will play and the video will not. Other times I get the same error. I’ve checked the hdmi port connection appears to be solid. 

0 Kudos
gottcent
Level 7

Re: After 3 Months OK, Blank Screen

By trial and error I stumbled upon a solution that has worked for over a week now. On my TV remote, I press Input and then switch to a different, empty, Input number. I wait a few seconds, then switch back to the Roku Input number, and voila! everything works.

0 Kudos