Features, settings & updates

Get troubleshooting tips to configure your Roku settings. The community forum has tips for screen mirroring, Guest Mode, software updates, audio, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Silverstar28
Reel Rookie

Roku linking/authorization to Google Home not working

Jump to solution

I am trying to re-link my Roku devices to Google home. I follow the instructions to link to Roku but after signing in to my Roku account it just hangs at the authorization page with a spinning circle.

I tried using my Samsung tablet and iPhone with the same results, spinning circle keeps showing and doesn't authorize.

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
RokuMary-F
Community Moderator
Community Moderator

Re: Roku linking/authorization to Google Home not working

Jump to solution

Hi Community users,

Thank you for reporting this issue to the Roku Community!

We're grateful for your patience regarding the issue you're encountering with linking Google Home or Alexa Support about two-step verification.

We're aware of the issue and the Roku team has been working on a fix for this but in the meantime, we do have 2 different workarounds. Please see below for steps on how to enable the Roku skills:

  • Two-Factor Authentication (2FA) Setup:
    • Sign in via the Alexa app or Google Home app, the 2FA page will appear.
    • tap “Didn't get an email? Try verifying another way.”
    • On the next screen, prompt the customer to enter the last 5 digits of the previously retrieved DID.
    • Finish enabling the skill.

One additional suggestion is turning off Website 2FA:

  1. Go to my.roku.com.
  2. Navigate to “Account info” and scroll to the bottom of the screen.
  3. Click the button below “Two Step Verification” to turn off 2FA.
  4. Verify that “Two-step verification is off” appears next to the button.
  5. click the “Save changes” button.

If you are still having any issues with your Roku device after following these steps, please provide your Roku device's serial number so we can assist further.


Best regards,
Roku Community Team

Mary F.
Roku Community Moderator

View solution in original post

0 Kudos
9 REPLIES 9
guyhouse4561
Reel Rookie

Re: Roku linking/authorization to Google Home not working

Jump to solution

I'm getting the same issue, it's just stuck and support hasn't provided a solution

0 Kudos
rbevans
Newbie

Re: Roku linking/authorization to Google Home not working

Jump to solution

Im getting the same issue - very frustrating

0 Kudos
RokuJechealR
Community Moderator
Community Moderator

Re: Roku linking/authorization to Google Home not working

Jump to solution

Hi Community users,

Thanks for reaching out to the Roku Community!

We apologize for any inconvenience this may have caused. We We would be more than happy to look further into this issue. What Roku device are you using right now? (e.g., Roku Express, Roku Streambar, Roku TV—specify TV) Are you encountering any error codes or messages? What other devices and their versions are you using to link your Roku device to Google Home? In addition, are you making sure that all the devices you are using are connected to the same network?

With more detailed information, we will be able to assist you further.

All the best,
Chel

 

Jecheal R.
Roku Community Moderator
0 Kudos
Silverstar28
Reel Rookie

Re: Roku linking/authorization to Google Home not working

Jump to solution

It's not the devices I'm using that's causing the issue, it's the authorization to link to Google home. 

You have to go through the Google home app to link, I've tried using the Google Home app on a Samsung tablet, iPhone, and even tried linking via 3 PCs all using the same home network.......same result. 

It just hangs on the spinning circle

 

But if  you are asking:

Device:

TCL Roku TV (2) Hard wired with Ethernet

Roku Ultra (5 devices) all hard wired with Ethernet

 

0 Kudos
guyhouse4561
Reel Rookie

Re: Roku linking/authorization to Google Home not working

Jump to solution

The same issue for me it's not a device issue, when trying to setup google by following these steps: 

 

How to set up Google on your Roku device

To use the Roku Action on Google, you need to link your Roku account to your Google account using the Google Home mobile app on your iOS or Android device.

  1. Launch the Google Home mobile app on your smartphone
  2. Tap the Plus icon
     

     

    in the top corner
  3. Tap Set up device from the list
  4. Select Works with Google
  5. Tap the Magnifying glass icon
     

     

    and search for Roku
  6. Select Roku from the list
  7. When prompted, sign in to your Roku account. Learn what to do if you forgot your email address or password.
  8. Select Continue and follow the prompts to return to the Google Home app

 

I have followed these steps on my iPhone multiple times and getting the same spinning loop page. 

Roku Device:

Roku TV - Sharp

RokuMary-F
Community Moderator
Community Moderator

Re: Roku linking/authorization to Google Home not working

Jump to solution

Hi Community users,

Thank you for reporting this issue to the Roku Community!

We're grateful for your patience regarding the issue you're encountering with linking Google Home or Alexa Support about two-step verification.

We're aware of the issue and the Roku team has been working on a fix for this but in the meantime, we do have 2 different workarounds. Please see below for steps on how to enable the Roku skills:

  • Two-Factor Authentication (2FA) Setup:
    • Sign in via the Alexa app or Google Home app, the 2FA page will appear.
    • tap “Didn't get an email? Try verifying another way.”
    • On the next screen, prompt the customer to enter the last 5 digits of the previously retrieved DID.
    • Finish enabling the skill.

One additional suggestion is turning off Website 2FA:

  1. Go to my.roku.com.
  2. Navigate to “Account info” and scroll to the bottom of the screen.
  3. Click the button below “Two Step Verification” to turn off 2FA.
  4. Verify that “Two-step verification is off” appears next to the button.
  5. click the “Save changes” button.

If you are still having any issues with your Roku device after following these steps, please provide your Roku device's serial number so we can assist further.


Best regards,
Roku Community Team

Mary F.
Roku Community Moderator
0 Kudos
Silverstar28
Reel Rookie

Re: Roku linking/authorization to Google Home not working

Jump to solution

Turning off 2FA seemed to have work for me, I was able to link Roku to Google home. 

 

Thank you.

guyhouse4561
Reel Rookie

Re: Roku linking/authorization to Google Home not working

Jump to solution

Turning off MFA worked for me also! 

 

Thanks! 

Horrorphan
Reel Rookie

Re: Roku linking/authorization to Google Home not working

Jump to solution

Turning off the 2 factor authentication worked.  Turn off 2 factor, proceed to link the Roku device to Google Home, make sure it's working, then turn 2 factor back on.   Works perfect!