Features, settings & updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Thomaso1920
Level 8

Re: [OS 10.5] Ultra 4660X channel issues and slowness

Jump to solution

Ok so here is the info you requested:

Software version : 10.5.0 build 4201-46

Model 4660x

Serial number: YJ005X1924**

Device ID: CK37A5192***

ALL CHANNELS ARE BROKEN

Error Network error

0 Kudos
JBZK
Level 7

Re: [OS 10.5] Ultra 4660X channel issues and slowness

Jump to solution

Roku 4670x here with the same problem since the 10.5.0 4201-46 build. Amazon Prime, Roku channel & Kanopy, will throw up a network error and not stream at all. All others are a crapshoot. Feed basically inaccessible. On the plus side, the home screen now has empty frames which once held obnoxious ads.

0 Kudos

Re: Multiple channel issues and slowness after 10.5 update

Jump to solution

I'm having similar issues. It seems to act like the network is really slow. I can't play anything on Paramount Plus or Vudu since the update. It was working great before this.

0 Kudos
Sausage1
Level 7

Re: No channels working after 10.5 update

Jump to solution

10.5.0 build 4201-46 on my ultra device stopped all my channels from working. Load time either errors out or loads extremely slow and can’t get any shows to play. I’ve tried rebooting, checking for new updates, reestablishing the network and nothing works. Horrible build. How did this pass QA??? Please fix or revert back to previous build asap!!!!

0 Kudos
KayJay62
Level 7

Re: No channels working after 10.5 update

Jump to solution

I have two Ultras. I started having the same problem described by many on this thread 2 weeks ago. Netflix plays, but Hulu won't load, stating "Network error, Criterion loads but won't play video, YouTube loads paimfully slow, after which the unit goes into sleep mode after failing to load a video. Even the Roku Channel shows "network error" The banner on the right side of the screen fails to appear etc.. In short, nothing works other than Netflix.) This happened with my older Ultra a few weeks ago, while the newer unit worked as normal. Now today, the newer unit has suffered a similar fate post-upgrade.

I bought these units about 6 months apart, and apparently they  didn't both simultaneously receive the upgrade. I thought initially there was something wrong with the first unit, and might have simply replaced it had the problem not suddenly reared its ugly head with the second unit a few weeks later, thus my trying to find out if it was an upgrade issue, and, well.. here we are.

Obviously, judging by the number of people on this thread, this is a common problem for a large number of us, and the OS 10.5 upgrade seems to be the obvious culprit as indicated by this discussion, (as well as info gleaned from some other sites, just to be sure.)

Roku Tech support needs to come through with a fix to remedy this problematic upgrade, otherwise my Roku players will have been rendered virtually useless, making me one very unhappy customer. At this point the company has to be aware of this problem.

0 Kudos
GrogeryH
Level 8

Re: [OS 10.5] Ultra 4660X channel issues and slowness

Jump to solution

Same issue with my 4660x Roku Ultra after updating to 10.5.0 build 4201-46.

Some apps launch eventually but are slow to load the interface elements and won't stream video at all.

The issue persists even after a factory reset of the device.

The issue was temporarily resolved after I power-cycled my Comcast-provided Cisco DPC3941T router but recurred after a couple hours. The Roku was the only device having any issues prior to the router reset and the Roku passes the network check even when the issue is occurring.

0 Kudos
KRICH
Level 7

Re: Roku Ultra November 17th update causing apps to load slowly and some don't work at all.

Jump to solution

4670X

YJ00F1099690

KWA02F099690

10.5 build 4201-46

ALL APPS EITHER WON'T LOAD OR ARE TERRIBLY SLOW

0 Kudos
OldClone85
Level 9

Is going back to Old software still available

Jump to solution

I would like to know how Roku can instruction us how to go back to 10.0 which worked quite well.

dreadprime
Level 8

Re: Is going back to Old software still available

Jump to solution

Is there a way to do this? I have two 4670X that are mostly useless now, but worked perfectly on 10.0.

mallan
Level 7

Re: Is going back to Old software still available

Jump to solution

I'd like to know if there's a way to roll back to a previous version, too. Last night my Roku Ultra was upgraded to 10.5 and now no channels will load. I have a wired connection and the connection check works fine, but every channel I try to watch says there is a connection problem. I've rebooted several times but the device is just plain broken. 

I'm extremely angry that they're still rolling out a buggy OS upgrade that breaks people's machines, I'll never purchase another Roku device if they don't fix this pronto.