Features, settings & updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Zoo23
Level 7

Nothing. Nada! Help! Turned on to and no signal!

Turned my TV on. 
no device found. (No signal)

unplugged. Restart button on roku. New batteries. 
NOTHING. 

What’s going on? Help. 

0 Kudos
3 REPLIES 3
DBDukes
Community Streaming Expert

Re: Nothing. Nada! Help! Turned on to and no signal!


@Zoo23 wrote:

Turned my TV on. 
no device found. (No signal)

unplugged. Restart button on roku. New batteries. 
NOTHING. 

What’s going on? Help. 


Um, there is no restart button on a Roku. There is a factory reset button, and that's a whole can of worms. Stay away from it unless you have to go down that road.

So, let's try to figure this out.

First, which Roku device do you have? The model number would be helpful. It's often on the device, and it's definitely on the box. It's four digits, followed by one or two letters. Ignore the letters.

Next, make sure your TV is selected to the HDMI port for the Roku, and that he port works. One way to confirm that is to plug something else into the port. Blu-Ray player, game system, anything that connects via HDMI. If you can see it, then the port is good and the TV is on that input.

If that doesn't resolve, ensure the Roku is getting power. The power supply could be bad. Does a light come on? Oh, are you powering it via the USB port on the TV. Some devices can be powered that way (I suggest never doing that, but many do). Is there a light on the Roku (depends on the model, one of the reasons that should always be included information)?

Do that and let us know how things stand afterwards.

DBDukes
Roku Community Streaming Expert
Note: I am not a Roku employee.

If this post solves your problem please help others find this answer and click "Accept as Solution."

0 Kudos
speds
Level 8

Re: Nothing. Nada! Help! Turned on to and no signal!

Same for me - brand new streambar - junk. HDMI ports not being recognized after the update ran. HDMI ports work (tested). I have plugged, unplugged, replugged, reset. You name it. It will let me reenter my network and rerun the update (in recovery mode) but as soon as the update runs it no longer recognizes the HDMI port. So frustrating that I purchased this thing - its now useless.

0 Kudos
DBDukes
Community Streaming Expert

Re: Nothing. Nada! Help! Turned on to and no signal!

@speds 

Really? I have a Streambar that recently updated to 10.5 and it works fine. I'm connecting on a 5 GHz network, so I don't know if that's a difference with your setup. I'm connected to a Vizio TV, for what that's worth.

Perhaps @RokuDanny-R or @RokuKariza-D can weigh in.

DBDukes
Roku Community Streaming Expert
Note: I am not a Roku employee.

If this post solves your problem please help others find this answer and click "Accept as Solution."

0 Kudos