Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Wireless connection ???? Help plz

I have 2 roku express plus and neither has wireless connection but I have excellent WiFi connection what do I do

0 Kudos
Community Streaming Expert

Re: Wireless connection ???? Help plz


There have been several different models released under the name "Express Plus" (I **HATE** that they do this, it sometimes needlessly complicates support issues).  For future reference, it's always a good idea to include your Roku model number (Roku menu path Settings > System > About).  You might want to determine your model number before proceeding.

There are a couple router setting issues that can prevent establishing Roku wifi connections. And to make matters worse, both of them can be caused by recently-reported router updates. These have primarily been reported with routers supplied by internet providers (Comcast/xFinity, Cox, and ATT so far), but it's possible they could also occur with user-owned routers that have received updates.

    Some router updates have changed the router's connection settings from b/g/n to just g/n, causing some Rokus connecting to the 2.4 GHz wifi band to lose their ability to connect to the network. The solution is to set the router's configuration back to using b/g/n. 
    A) Router updates have been reported which deactivated the router's 2.4 GHz wifi band, leaving only the 5 GHz band in operation.  Roku Express/Express+ (not the relatively new Express 4K/4K+ models 3940/3941) and Premiere/Premiere+ (model numbers above 4620) are lower end units with single band Wi-Fi radios that only support the 2.4 GHz band. They, and many other devices of all sorts that are 2.4 GHz only, can't even see the 5 GHz band, let alone connect to it. If you have a 2.4 GHz only Roku model and a dual band router with both 2.4 and 5 GHz bands, be sure the router's 2.4 GHz band is turned on.

    B) All Rokus support channels 1-11 in the 2.4 GHz WiFi band, as are used in North America. If your router supports 2.4 GHz channels outside this range make sure your router is set to use a channel in this range and that you aren't using an auto setting that could select channels outside this range.

    C) Rokus with dual-band wifi radios can connect to the 5 GHz wifi band in two ranges of channel numbers, 36-48, and 149-165. If your router supports 5 GHz channels outside these two ranges make sure your router is set to use a channel with these ranges and that you aren't using an auto setting that could select channels outside these ranges.

    If this problem was not caused by a router update deactivating the 2.4 GHz band, often a restart of the router (even if other devices are still connecting) followed by a restart of the Roku will allow the connection to be reestablished. Depending on your Roku model and Roku version number you'll find the System restart option under either Settings > System or Settings > System > Power, or if more convenient you can just remove the Roku's power for a few seconds and let it restart.

For either of these issues, if you need to make configuration changes on equipment supplied by your internet provider but you have no access to its settings, you may need to request your internet provider to make the changes for you.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X

Re: Wireless connection ???? Help plz

Has this been stickied somewhere? This was driving me nuts for the past week. I was able to make the change to my router and it's working again, but it really was frustrating for days and days.

0 Kudos