Wi-Fi & connectivity

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Unable to update software - Error Code 005 - USB & Network

The audio on the television was cutting out for 10-20 seconds at a time sporadically, particularly on Disney Plus App.  I checked for updates and found one was available.  (The last update was May 13, 2021.). I selected Update and the TV wouldn't update. After power cycling the TV, and selecting update it would get to about 24% and stop with an Unable to Update Error 005.  I performed a Factory Reset to remedy the issue with worse results.  I now have no access to my account/apps (on TV) and I'm unable to add the display back to my account.  I have disabled the firewall on our network and ensured there are no network blocks preventing the display from reaching the destination.
**I DO NOT have the ability to run a separate wifi hotspot network, nor take the display to a secondary location to attempt to update.  I cannot foresee any network issues as being a primary culprit as the network configuration has not changed and thus shouldn't be the primary offender.  I also believe this is supported since the television will not update via USB either.

Here's the rundown of the specs:
50" Sharp with a hardwired connection
Version: 38A.00E04195A
Build Date: 20210504 21:34
Software Update Server: release (I also tried beta)
Channel Store Server api.roku.com()
Roku TV 7202X
Sharp Model LC-50LBU591U
Software Version 10.0.0 - build 4195-38

Hardwired Connection - OK (also tried on Wireless Connection with same results)
Update Available - Click OK -  Error 005

Check For Updates - Update Available
TV will update to to
Update Now - Error 005

Downloaded Update Firmware from tvupdate.roku.com to USB
Ran USB Test - OK
USB Status: OK - Expected time =140, Actual Elapsed test time = 110

Select to Update Software on USB
Contents of the update file are invalid. Please try again

As previously stated.  The display is in Factory Reset Mode and I'm unable to access any apps on my account.

0 Kudos
Community Streaming Expert

Re: Unable to update software - Error Code 005 - USB & Network


The easiest troubleshooting steps are those unfortunately unavailable to you (using another network or the hotspot technique).  Being the situation, see if below helps.  

In order to cover all bases...Unplug the ethernet cable from your TV and router.  Turn TV off for 5-10 min.  Then reinsert ethernet cables, reboot router and plug in your TV again.

First make sure that your router is seeing the Roku as connected with the wired or wireless connection connection. (Router should be showing an IP address and MAC address).  Try using the ethernet connection first.  If you are not seeing an IP address or the device listed in the router, try using a different ethernet cable.  If you are still not seeing an IP address or seeing all zeros,, indicates potential initial problem with the the ethernet cable/ethernet port or the DHCP server/configuration of the router.

Since you know how to access the debug/secret screen, do another factory reset (fresh start), 30+sec hold of the reset button.  This next step apparently will not work if an error code has previously been thrown, so unfortunately you need to factory reset again to clear the code. Now go through the setup again until you reach the message indicates "Software Update" needed.  Instead of pressing "Ok" button to proceed, enter the debug screen at this point (Home 5x, FF 3x, Rew 2x), and manually select "Update Software" (release version).  Note here that before you select "Update Software" you should be seeing an IP address to the left of the menu options that should be matching the one you saw at your router.  Pay particular attention to the subnet.  (Again, if you are seeing all zeros here, you will need to reboot the router and Roku and try again.)  An IP address has to be visible before connection and updates can occur. 

If you are able to get through the update successfully in this manner, you should be good to go from there.  

If still having trouble, post back with your router model number and more detail with your network setup. (ie using multiple routers, access points, switches, VPNS, etc.) 




Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941
0 Kudos