Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ConradC
Reel Rookie

Roku will pick up IP but gateway remains at 0.0.0.0

Jump to solution

An extremely strange issue I've never seen before. I have 3 Roku Ultras (4660X). Two are hardwired and one is on wireless. All three seem to pick up an IP address via dhcp just fine but their gateways remain at 0.0.0.0. I can see the gateway on the hardwired ones and I'm assuming the wifi has 0.0.0.0 as well. I can ping them locally. No issues with any other devices on the network, they all can access the internet just fine (with gateway populated). I've reset the network settings on the Roku without success. Issue seems to be limited to only the Rokus. I've also rebooted a few times. Before I go and try a factory reset, any idea what the issue could be?

Labels (2)
1 Solution

Accepted Solutions
ConradC
Reel Rookie

Re: Roku will pick up IP but gateway remains at 0.0.0.0

Jump to solution

I was able to resolve the issue myself.

TLDR: DHCP policy with multiple gateways.

While I was waiting for Roku support, I decided to setup a SPAN port on the Roku. I sniffed out the DHCP request and found out multiple gateways were leased out. This was an old policy that was suppose to be deprecated, but was still active. The policy has been there for a few years. Why it only affected the Roku(s) recently is what puzzles me. They were working fine for years. I removed the policy and bounced the Roku(s). They were able to set the correct gateway properly.

I wish there was a way to set static IP info directly on the Roku themselves. Not sure why it's not an advance option.

View solution in original post

0 Kudos
4 REPLIES 4
AvsGunnar
Community Streaming Expert

Re: Roku will pick up IP but gateway remains at 0.0.0.0

Jump to solution

@ConradC 

Came across your posting and wondering if still experiencing problems or if the factory reset fixed your issues.

Normally, the 0.0.0.0 gateway issue is more a switch-layer problem in networks (at router or access points/bridged routers,etc).  (default gateway vs. ip-route)

Older Linksys routers also had this issue during dhcp assignment.  If you are still having issues, post back with your router model number and your network setup (single router/modem, access points, etc) and the Roku OS you are using 9.4 or 10. 

If you know how to configure your network and manage your router, and the Roku Ultras worked previously, I would simply factory reset the router.  (Normally enough to fix/eliminate corrupted router settings as problem... I additionally clear the NVRAM after reset but not required.)

There are some Roku menus you can access to see if your wireless Ultras are experiencing similar issues with gateway 0.0.0.0 like your wired, so post back if interested and still troubleshooting.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos
RokuDanny-R
Retired Moderator

Re: Roku will pick up IP but gateway remains at 0.0.0.0

Jump to solution

@ConradC

Thanks for the post.

Can you please provide us the following information:
-Roku device model
-serial number
-device ID
-software OS/version
(these can all be found in Settings > System > About)
-when did you start to see this issue occur

With more information we will be able to investigate the issue further.


Thanks,
Danny

Danny R.
Roku Community Moderator
0 Kudos
ConradC
Reel Rookie

Re: Roku will pick up IP but gateway remains at 0.0.0.0

Jump to solution

I was able to resolve the issue myself.

TLDR: DHCP policy with multiple gateways.

While I was waiting for Roku support, I decided to setup a SPAN port on the Roku. I sniffed out the DHCP request and found out multiple gateways were leased out. This was an old policy that was suppose to be deprecated, but was still active. The policy has been there for a few years. Why it only affected the Roku(s) recently is what puzzles me. They were working fine for years. I removed the policy and bounced the Roku(s). They were able to set the correct gateway properly.

I wish there was a way to set static IP info directly on the Roku themselves. Not sure why it's not an advance option.

0 Kudos
Raftergreg
Newbie

Re: Roku will pick up IP but gateway remains at 0.0.0.0

Jump to solution

We experienced loss of wireless internet on my TCL Roku equipped TV for no apparent reason....showing strong wireless signal from router but would not connect (we have Eero extenders, but shouldn't matter).  Went through all the resets...router and TV hard resets (pull the power cords for 30 seconds), tried the basic reconnect option process from the Roku menu.  Finally noted the IP address had reset to 0.0.0.0 (check by going to Home menu>Settings>System and you'll see the IP address). Other Roku equipped TVs in the house had no issues/proper IP addresses).  I'd initially tried a software update with no success, but gave it a second try a day later and it worked.  Settings>System>Software update.  You may then have to go through the basic Roku network reconnect menu (Settings>Network>Set up connection), but problem solved.  Try and try again I guess.

0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.