Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Bigski724
Reel Rookie

Re: Roku not showing hotel prompt

I am sorry that so many people are having difficulty.   I have used mine at about 20 different hiltons over the past few months.  Each time it has worked flawlessly.   My settings/ process is as follows:

1) roku express HD

2) samsung s20 phone

3) select hilton wifi in roku

4) it asks for home/dorm question

5) answer yes

6) connect with my phone to roku wifi.  Here I have to ensure that Verizon doesn't try and switch my wifi as it thinks the roku wifi has no connectivity.  I select remain on roku wifi.

7) open browser to 192.x.x.x whatever roku wifi directs me to on the phone

😎 enter hilton login info on the roku web page 

9) all works fine and I am connected to the premium hilton wifi

I have not tried it with other hotel chains.  I wonder if some roku devices do not have the hotel feature.  The express HD with the latest update detects the hilton service every time.  Hope this helps somebody.  

0 Kudos
atc98092
Community Streaming Expert

Re: Roku not showing hotel prompt

@Bigski724 Yep, that’s how mine have worked for years. But with 10.5 something broke, and at some hotels (Marriott seems to be a major one) the hotel prompt is never appearing, so there’s no way to connect a phone or something with a web browser to access the Authenticator page. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos
en0
Newbie

Re: Roku not showing hotel prompt

Here is a workaround for the prompt not showing in some hotels. 1) Reset Roku’s network settings to disconnect from hotel’s wifi, 2) Spoof Roku’s MAC address from your laptop (on macOS I used spoof-mac), 3) Connect to hotel’s wifi from laptop, 4) Sign in through laptop’s captive portal prompt, 5) Reset laptop’s MAC address, and then 6) Connect to hotel’s wifi from Roku. The MAC address should be recognized as registered and let your Roku connect to the internet. Results may vary. I’ve just done this at a MarriottBonvoy hotel with successful results.

atc98092
Community Streaming Expert

Re: Roku not showing hotel prompt

@en0 nice suggestion. That particular idea won't work when I travel, as my work laptop is locked down too tightly for me to be able to spoof the MAC address. And I don't travel with my personal laptop. 🙂

I've noticed that Marriott has changed their authentication page. One used to be able to select the number of days you are staying, and the connection would be good for that long. I was staying long term a few years ago and it allowed me to set it to 30 days. But now they seem to already know how long you are staying, and my connection stayed good through the length of my stay. I always thought they should have been able to know that info, and not ask on a daily basis. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos
Joshufl85
Reel Rookie

Re: Roku not showing hotel prompt

The Roku stick is complete junk. Amazon does a way better job with public internet connections using an in app browser. Never had an issue until switch to Roku. Now I have the same issue is everyone else. It is clearly some type of software issue that has been going on for years. What a joke. Back to Amazon it is.

0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.