Wi-Fi & connectivity

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Ricks42879
Level 7

Roku not connecting to my wireless

I have 4 TV’s. 3 through roku that won’t connect to my wireless. The one smart tv I have that is not through roku is working fine. I can also play XBox. I have unplugged them several times. I have also unplugged my wireless and cable internet box. Anyone else. Can’t find a phone number to help me

0 Kudos
5 REPLIES 5
RokuKariza-D
Roku Employee
Roku Employee

Re: Roku not connecting to my wireless

Hi @Ricks42879

Thanks for reaching out here in the Community!

Could you provide us with the model number of your Roku devices? These can be found in Settings > System > About. Please also reply here with who your internet service provider is. 

We'll be able to further assist you from there.


All the best,
Kariza

Kariza D.
Roku Forum Moderator
0 Kudos
makaiguy
Community Streaming Expert

Re: Roku not connecting to my wireless

@Ricks42879-

What models and model numbers are your 3 Rokus?  Roku menu path Settings > System > About on each will tell you.

There are some router setting issues that can prevent establishing Roku wifi connections. And to make matters worse, some of them can be caused by recently-reported router updates. These have primarily been reported with routers supplied by internet providers (Comcast/xfinity, Cox, and ATT so far), but it's possible they could also occur with other internet providers or user-owned routers that have received similar updates.

  • ROKU LOCATES NETWORK AND REPORTS NETWORK QUALITY BUT CANNOT CONNECT
    Some router updates have changed the router's connection settings on the 2.4 GHz wifi band from b/g/n to just g/n, causing some Rokus and some other devices connecting to the 2.4 GHz wifi band to lose their ability to connect to the network. The solution is to set the router's configuration back to using b/g/n.
     
  • ROKU CANNOT FIND LOCAL WIFI NETWORK AT ALL
    A) Some recent router updates have turned off the router's use of the 2.4 GHz band, leaving only the 5 GHz band in operation. Some Roku models, notably Roku Express/Express+ (not the relatively new Express 4K/4K+ models 3940/3941) and Premiere/Premiere+ (model numbers above 4620), are lower end units with single band Wi-Fi radios that only support the 2.4 GHz band. They, and many other devices of all sorts that are 2.4 GHz only, can't even see the 5 GHz band, let alone connect to it. If you have 2.4 GHz only Roku model and a dual band router with both 2.4 and 5 GHz bands, be sure the router's 2.4 GHz band is turned on.

    B) In the 2.4 GHz WiFi band, all Rokus support channels 1-11, as are used in North America. If your router supports 2.4 GHz channels 12-14 as are used in other regions, make sure your router is set to use a channel in this range and that you aren't using an auto setting that could select channels outside this range.

    C) Rokus with dual-band wifi radios can connect to the 5 GHz wifi band in two ranges of channel numbers, 36-48, and 149-165.  If your router supports 5 GHz channels outside these two ranges make sure your router is set to use a channel with these ranges and that you aren't using an auto setting that could select channels outside these ranges.

Thanks to forum user @AvsGunnar for providing the links below to instructions for reconfiguring router settings for the listed internet suppliers. If you can't do this yourself, you may need to contact your internet provider to make these changes for you:

If your problem was not caused by any of the above, often a restart of the router (even if other devices are still connecting) followed by a restart of the Roku will allow the connection to be reestablished. Depending on your Roku model and Roku version number you'll find the "System restart" option under either "Settings > System > Power" or "Settings > System", or if more convenient you can just remove the Roku's power for a few seconds and let it restart.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X
0 Kudos
Ricks42879
Level 7

Re: Roku not connecting to my wireless

all 3 are roku express. The one i can access right now is 3900X - Roku Express. Was on chat 3 times with roku. They had me do a factory reset and re activate (didn't work). All other (other then Roku) devices continue to work fine. I have a smart TV that is streaming hulu live right now and also an Xbox that is giving me no trouble. I have been streaming 2 years now using ruko with no trouble. Wake up today and they don't work. The last thing that the chat guy could do for me was tell me to contact my ISP. Then they said happy steaming lol

0 Kudos
Ricks42879
Level 7

Re: Roku not connecting to my wireless

I forgot to mention. I own my router. It is an apple airport. My ISP is MCTV.

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: Roku not connecting to my wireless

@Ricks42879

Thanks for the post.

If you are currently in contact with our Support team, we would recommend continuing to work with them as they would best be able to assist you moving forward regarding your issue.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos