Wi-Fi & connectivity

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
RokuKariza-D
Roku Employee
Roku Employee

Re: Roku Ultra - wireless network issues - no Interference menu option

Hey @okiimatsu

We're here to help!

We do not have enough details from your original message to make an effective suggestion. Could you tell us more about your concern?

With more information, we can assist you further.


All the best,
Kariza

Kariza D.
Roku Forum Moderator
0 Kudos
schexc
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

All the information you need is in the last twelve pages, dating back to February of 2019. Same problem then, same problem now.

ChefZ
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

If you are going to use Ethernet and IR remote only, it's a no brainer to open up the device and physically remove the metal antennae.

 

This issue has been open for a very long time and I wouldn't expect a software / firmware fix to simply return the secret menu functionality that was taken away

walt3k
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

Kariza,

22 hours ago the firmware was updated on my Roku3 and now the option to turn the wifi off is gone.  I, along with many others you can read about in this and other forum posts cannot use the device without the ability to turn the wifi off.  Please escalate this issue ASAP to the Roku technical team and ask them to reinstate the control they used to provide!  Thx,  Walt.

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: Roku Ultra - wireless network issues - no Interference menu option

@walt3k

Thanks for the post.

We would be more than happy to look further into this issue for you. Can you please provide us the following information:
-Roku device model, serial number, device ID, and software OS/version (these can all be found in Settings > System > About)
-steps to reproduce the issue you are seeing
-screenshot of the issue

With more detailed information, we will be able to assist you further.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
walt3k
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

Sure, thx!

Roku device model, serial number, device ID, and software OS/version?
 4200X, 1GU446096063, FCC ID=TC2-R1004, Software version 11.0.0 - build 4184-04

steps to reproduce the issue you are seeing?
24 hrs ago the Wifi on my Roku was off because there was an option to turn it off under Settings->System->Advanced    I don't remember what the option was called because I set it a long time ago and never changed it.

screenshot of the issue?  There used to be an option on this screen below which essentially turned the Wifi off.  I have all the other discover options on other screens off.  Is the option to turn off Wifi somewhere else now?  Is there another way to control it?  Maybe back on the hidden menu? Thx for the help!

 

roku_small.jpg

 

0 Kudos
okiimatsu
Level 8

Re: Roku Ultra - wireless network issues - no Interference menu option

Yes, i've actually done this experiment now. Have a Roku 3. Removed the antennas and switched to IR remote. Still does not work. The Roku Parasite knocked out my wifi twice in thirty minutes. I covered the Roku with an rfid shielding case I had, did'nt help either. Completely unplugged/disconnected the roku and my wifi has been just fine for days, no dropouts. Thanks for all your suggestions!(ChefZ etc.) (also had my isp out twice within a week to physically check my line; they also gave me a new wifi modem just in case. It's not my service or equipment causing this.)

I understand Amazon has been aware of the wifi direct problem with some of its firestick devices. They switched to a bluetooth signal for the 4k version and peeps are saying its eliminated the problem. 

0 Kudos
tecnodweeb
Level 7

Re: Roku Ultra - wireless network issues - no Interference menu option

Just found a setting which appears to disable WiFi Direct on a Streaming Stick+ 3810EU (without disabling the Roku’s WiFi connection, and leaving it controllable via the Roku app on a smartphone):

Access the Wifi secret screen (as outlined in previous posts), then select the Resets sub-menu, and then select the “P2P down” option.

This will immediately stop the wireless/voice remote from working so make sure you have another means (e.g. Roku app on smartphone) to carry on controlling the device.

There doesn’t appear to be a menu option which will re-enable P2P, however it comes back after a reboot (be patient whilst the wireless remote reconnects!).

0 Kudos
Kbickhaus
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option

Hey I’m glad you tried it and worked for you as well!

0 Kudos
ChefZ
Level 9

Re: Roku Ultra - wireless network issues - no Interference menu option


@okiimatsu wrote:

Yes, i've actually done this experiment now. Have a Roku 3. Removed the antennas and switched to IR remote. Still does not work. The Roku Parasite knocked out my wifi twice in thirty minutes. I covered the Roku with an rfid shielding case I had, did'nt help either. Completely unplugged/disconnected the roku and my wifi has been just fine for days, no dropouts. Thanks for all your suggestions!(ChefZ etc.) (also had my isp out twice within a week to physically check my line; they also gave me a new wifi modem just in case. It's not my service or equipment causing this.)

I understand Amazon has been aware of the wifi direct problem with some of its firestick devices. They switched to a bluetooth signal for the 4k version and peeps are saying its eliminated the problem. 


The Roku 3 internals look a bit different to the Roku Ultra.  I would go back in and make sure you don't have any continuous metal strip running across diodes. You want to make sure its impossible to complete any circuit otherwise the device can still generate a signal.  Just to be safe i covered any exposed metal surfaces at each diode with electrical tape before closing it back up.

If you successfully remove the antenna and eliminate the circuit, then it shouldn't be able to generate a signal.

0 Kudos