Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reel Rookie

Roku Ultra 4800R Needs Reboot, Network Connection Reset, or Both Before Watching Channel Content

I just replaced my Roku 3 with a Roku Ultra. On the Roku Ultra if I open an app (say Hulu or Discovery plus) and select the content I want to watch, the channel app will freeze in mid-load or give me a "can't play, try later" error. Sometimes during the freeze I can back out to Home. Other times the system reboots. If it backs me out to home, I can go to reset my network connection. The Roku reboots and I can play my content.  If the system reboots sometimes I can just go back to the content I was trying to play and it plays. Other times I have to go to the reset network connection and it will play. 

At first this was limited to Discovery +, Hulu, Netflix, and CBS All Access. Disney + and YouTube seemed to work ok. However tonight now YouTube is exhibiting this behavior.

I'm using a wired connection. I have tried uninstalling, clearing the cache and installing the channels. I've tried a factory reset. As I said above the problem actually seems to be getting worse. 

Is there some sort of router or home network setting that I need to change? Didn't have any problem with the 3. It was just getting very old and didn't support the higher resolution content. It did however play content without having to do the reboot/restart cha-cha. Maybe I'm stuck with life at 1080. 

0 Kudos
Reel Rookie

Re: Roku Ultra 4800R Needs Reboot, Network Connection Reset, or Both Before Watching Channel Content

More information on this. If I reset the network connection before opening a channel, I can watch the content fine. If I leave the channel and try another channel without doing the reset that channel will freeze and the Roku reboots (or I have to reboot it). However, if I leave the channel and do a network reset I'm fine. So, it seems like a network problem.

I tried assigning a specific IP address to the Ultra thinking DCHP might be the culprit, but it didn't help. I'm going through an AT&T residential gateway, so you can't set QoS.  Feel like maybe there's some firewall setting or something that may be messing things up. 

Just an FYI I also tried some non-network stuff I've seen in the forums (I tried changing resolutions all the way down to 720. Changed HDMI cable as well.)

0 Kudos