Wi-Fi & connectivity

Help & troubleshooting for network issues, including connecting your device to your home Wi-Fi network, connecting to public networks, troubleshooting wireless issues & ethernet connections, and optimizing streaming performance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
atc98092
Community Streaming Expert

Re: Problems Connecting to Closest Unifi Access Point


@PhantomQuad wrote:

Hi there, just wanted to share my findings after experiencing the exact same issue but with 2 x Unifi AP's

 

I found that to Roku would not detect the 5GHz signal from the AP that was 1 meter away because of the channel that AP was using for 5GHz... It was using channel 120(DFS) there was no issue after forcing it to use channel 40. I haven't played around with this much because I'm happy it works now but I suspect the Roku may have issues detecting the channels that are (DFS) Dynamic Frequency Selection.


This is correct. Roku devices with a 5 GHz radio will not see or use a DFS channel. So you need to use channel 48 or lower, or 149 or higher. Because of the potential for interference with larger devices that use the same frequencies as the DFS channels (differs by country), Roku (and other companies as well) elected to simply not use those channels. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
Schiffy
Level 8

Re: Problems Connecting to Closest Unifi Access Point

Thanks PhantomQuad. I haven’t used it in a while but I can try to change the channels next time I mess around with it. I’m pretty sure the closest two APs are on 1 and 13 I can double check. 

0 Kudos
atc98092
Community Streaming Expert

Re: Problems Connecting to Closest Unifi Access Point


@Schiffy wrote:

Thanks PhantomQuad. I haven’t used it in a while but I can try to change the channels next time I mess around with it. I’m pretty sure the closest two APs are on 1 and 13 I can double check. 


Channel 1 and 13 sounds like 2.4 GHz channels, and Channel 13 is not permitted for use in North America. For 2.4 GHz, channels 1-11 are all that are allowed. 

In the 5 GHz band, the non-DFS channels for the US are 32-48 and 149-165. That actually applies to Canada as well. Any other 5 GHz channel is not allowed to be used. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos
spyd4r
Level 7

Re: Problems Connecting to Closest Unifi Access Point


@PhantomQuad wrote:

Hi there, just wanted to share my findings after experiencing the exact same issue but with 2 x Unifi AP's

 

I found that to Roku would not detect the 5GHz signal from the AP that was 1 meter away because of the channel that AP was using for 5GHz... It was using channel 120(DFS) there was no issue after forcing it to use channel 40. I haven't played around with this much because I'm happy it works now but I suspect the Roku may have issues detecting the channels that are (DFS) Dynamic Frequency Selection.

 

Hope this helps as I was sure my AP was faulty before figuring this out 🙂


Holy **bleep**. Thank you SOO much. I was fighting with this for a month trying to figure it out. What a pain in the **bleep**, thanks Roku.

0 Kudos
dstolt
Level 7

Re: Problems Connecting to Closest Unifi Access Point

This is spot on.   Thanks for posting this as I had to turn off the DFS channels in my meraki gear and it worked like a charm!

0 Kudos
plittlefield
Level 7

Re: Problems Connecting to Closest Unifi Access Point

Thank you for this post.  It’s just fixed the problem with my Roku Streaming Stick+ connecting to my UAP at the other side of the house, not the one in the same room!  This was because the nearest access point was using channel 120 for 5GHz.  Once I changed the channel to 44 and reset the Roku Network Settings it connected to the UAP in the same room with 100% strength and the problem was fixed!