Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Not recognizing my internet--Two Express 4K+ units. One works, the other won't

I am trying to set up on the 5G channel. My first Unit connected successfully. The second,identical unit will not access the network. I tried swapping out the units, trying the second unit where the first worked in the kitchen. No success. I have reset the unit. Nothing changes.

All the articles say "return to home and access the settings" I am stuck in the setup and the unit will not return to the home menu.

I tried to return the unit but when I enter the serial number, I get "please enter, a valid serial number."

I am completely new to the no-cable world and I am floundering here. I'm sorry I ever bought Roku. The support options stink.

And, what exacly is a phone hotspot? How does one set one up? 

I have a new TP-Link Archer AX-50 router.

Labels (1)
0 Kudos
Roku Guru

Re: Not recognizing my internet--Two Express 4K+ units. One works, the other won't

So you bought 2 Roku Express 4K at the same time? Are you 100% positive both are the 4K model? Both have the exact same model number? Only reason I am asking this is cause the non 4K Roku Express only does 2.4GHz. Have you tried the 2.4? Verify both are the same model


Community Streaming Expert

Re: Not recognizing my internet--Two Express 4K+ units. One works, the other won't


Here are some simple instructions on how to use your phone as a hotspot depending on whether Android or Apple. (https://www.highspeedinternet.com/resources/how-to-use-your-phone-hotspot)


Exactly where are you with the non-working unit.  Are you still trying to setup, or is it setup/activated and you are at home screen but unable to connect to your network.

If you can figure out the hotspot, that is a good procedure to at least get through setup.  Alternatively, you can bring to someone else's network and try to set up and test.  If none of these options are available to you, we will have to work with what you have.

There are different ways to proceed.  If you are using the same SSID (network name) to connect your devices, regardless of 2.4ghz or 5ghz band, then you can do either of the following to try initially...

1. Assign a different name to the 2.4 ghz band unique from the 5ghz band.

2. Disable the 2.4ghz band so forces connection on 5ghz band.

3. Disable the 5ghz band so forces connection on the 2.4ghz band.


Once you get the Express 4k+ to connect to network, then able to tweak some settings and see why having such difficulty.

Of course, I am assuming here that you have tried to restart your Router as well as the problem Roku device.  Even when everything else seems to be working, if the router loses connection with a Roku device, it may be necessary to restart both to regain connection.

Feel free to post back with an update or if you need more help.  Provide as many details as you can (what seemed to work, what didn't work, any error codes on screen etc.)  Also include your Roku model numbers and ISP (internet service provider).

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102