Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reel Rookie

How to cast to Roku TV from my Android phone

We have 2 Roku TVs, one is a Sharp and one is TCL. Neither of them show up on Android cast screen. They're all on same WiFi and setting on TVs are correct. Any ideas?


0 Kudos
Community Streaming Expert

Re: How to cast to Roku TV from my Android phone


The "Cast" feature on your Android phone will only show up (display available devices) when compatible, castible content is available for the Roku (ie. Youtube and Netflix, some others).

If you play a Youtube video on your phone, you should be able to "Cast to TV" from within the Youtube video, or go to the Android's "Cast" setting and should see an available TV to connect to (all need to be on same network as you indicated).  

If you want to be able to Cast all available web-content (not just chromecast compatible) to your Roku, then look at the various web casting apps in the Play Store.  I use the free versions of "Web Video Cast", Castify/Rokify, and "Video & TV Cast for Roku".

Some basic info here on the Casting of Android. https://awajis.com/android-cast-feature/ 


Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos
Roku Guru

Re: How to cast to Roku TV from my Android phone


Its not clear whether you are casting from an app, or mirroring from the device (brand/model unknown).

Casting=from app, Mirroring=from device

If you are trying to mirror (using Miracast) your device:

1) Verify screen mirroring of Roku is configured/working properly:

   A) Settings/System/Screen mirroring/Screen mirroring mode=Prompt

   B) Settings/System/Screen mirroring/Screen mirroring devices/Always blocked=none

   C) Settings/System/Advanced system settings/Device connect=Enabled

   D) Settings/System/Advanced system settings/Control by mobile devices=Default

   E) Always select "Always allow" when prompted by the Roku

   F) Test with (another) Android/windows Miracast-capable device

2) Workarounds/solutions:

   A) Disable/re-enable WiFi connection of phone/tablet/PC - try again

   B) Restart Roku/phone/tablet/PC/modem/router/gateway - try again

   C) Switch Roku and/or phone/tablet/PC to 2.4Ghz SSID or 5Ghz SSID - try again

   D) Delete all devices under Always Allow - try again