Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Sangaris
Reel Rookie

Doesn’t show WiFi as an option

None of my 4 Rokus will show my WiFi as an option. I tried typing it in as a private network, but that doesn’t work either. Restarting and unplugging didn’t work. Since it can’t connect to the internet, it can’t be updated. All other devices connect just fine. 

Roku Stick, Express, Express 4K, and Ultra

error 014.30

0 Kudos
5 REPLIES 5
RokuKarla
Retired Moderator

Re: Doesn’t show WiFi as an option

Hello @Sangaris

Thanks for posting in the Roku Community!

For your Express or Roku Premiere device, please note that this is only compatible with wireless b/g/n networks on the 2.4 GHz network. In order for the device to connect, confirm that your router is broadcasting a 2.4GHz Wi-Fi network. You can check your device model by navigating to Settings > System > About.

If you are getting an error code or message, refer to this link for common Roku error codes and their recommended actions: How to connect your Roku® streaming device to the internet using Wi-Fi® or Ethernet 

Let us know how it goes!


Regards,
Karla

0 Kudos
atc98092
Community Streaming Expert

Re: Doesn’t show WiFi as an option

Since you have a variety of different Roku players, and none are finding your WiFi, the answer is likely the WiFi channel in use on your router. For your 2.4 GHz only Roku player (the Express), the channel has to be 1-11. If your router is self-assigning 12, 13 or 14, your Roku won't see it. For the 5 GHz capable devices (all the rest) the channel has to be one of the non-DFS channels. So the channel has to be 48 or below, or 149 or higher. Also, make sure both your 2.4 and 5 GHz radios are turned on. Some ISPs that have control of your router have recently been turning off the 2.4 GHz radio.

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos
Sangaris
Reel Rookie

Re: Doesn’t show WiFi as an option

@RokuKarla they’ve all been connected to the WiFi before today. 

0 Kudos
Sangaris
Reel Rookie

Re: Doesn’t show WiFi as an option

@atc98092  It is 2.4GHz, but I’m not sure about the channels. Why would this happen all of a sudden?  They were working fine yesterday. 

0 Kudos
atc98092
Community Streaming Expert

Re: Doesn’t show WiFi as an option

Most routers are set to Auto for channel selection. This means the router can and will at times change the channel in use. For 2.4 GHz, the best channels to use are 1, 6 or 11. 

Dan

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee, just another user.
0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.