Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
twomp6
Channel Surfer

Re: Cannot Connect to Wi-Fi for 2 Days.

Jump to solution

The issue is not with my wi-fi or internet connection. I have no problems with my ISP or connecting to other devices and have not at any time. Everything I have works fine and I have never had any problems. That goes for laptops, personal computer, tablets , tv's, cell phone, bluetooth devices. The issue is with the roku device which is why I posted my comment in the forum. The roku I bought does not have an ethernet plug and I am most certainly not going to buy another roku device because the one I purchased has issues connecting to wi fi due to a product issue, manufacturer defect, flaw or whatever the case may be. 

I have saved the link that was posted and it is appreciated if I am in dire need of trying to get my roku to possibly function I will proceed accordingly with due diligence. Thanks for the comments and concerns. 

0 Kudos
Strega
Roku Guru

Re: Cannot Connect to Wi-Fi for 2 Days.

Jump to solution

Yes that's the way it goes.  Your Wi-Fi is usually fine, except for.... 

0 Kudos
Ello2022
Roku Guru

Re: Cannot Connect to Wi-Fi for 2 Days.

Jump to solution

Bluetooth devices don’t connect through your modem. Laptops, computers, smartphones and tablets are dual band. They can run on 2.4 or 5.0. Many years ago I bought a pack of Gosund Smart plugs so I could remotely control my lights. There was no instructions in the box. Bought it off Amazon. I found some generic instructions. The Gosunds would not connect to my WiFi. Took me hours. Finally I found a YouTube video. The Gosunds only work on the 2.4GHz. My phone was on 5.0. So I had to switch my phone to 2.4 then use the Gosund app to program the plugs. Now it works. Older Ring doorbells only worked on 2.4. In today’s world it’s not uncommon for devices still to only work on the 2.4 GHz

0 Kudos
Strega
Roku Guru

Re: Cannot Connect to Wi-Fi for 2 Days.

Jump to solution

By the way, I understand priorities and not getting to stuff.  Early in the pandemic, I found that Zoom wasn't working well on my Wi-Fi and suddenly I needed a whole lot of Zoom.  This is kind of odd because the devices that were running Zoom worked on Wi-Fi for everything else – but technology is like that.  That was eventually fixed by plugging into ethernet.  (High priority and mission critical so it got fixed.)

As you can imagine, this problem came up a lot.  I saw people freeze and drop off my zoom meetings and I saw people complaining about it at my ISP and other places.  So, I told people what worked for me and some people did it and reported success.  However, some people were unhappy that they had to do something – I mean that's kind of understandable, because, for example, in my case I had to buy a USB to ethernet adapter for my laptop and then rearrange my furniture and lighting to make having meetings near the router workable.  But it was a solution that absolutely works – Zoom is rock-solid on ethernet.  By comparison, some people I still meet with have still made no such accommodations and they are still freezing and sometimes even dropping out of meetings entirely. Oh well, priorities vary I guess...

Anyway, the point is, many issues can be solved or worked around if you are willing to do a little work, and if you post in a forum, people are going to try to make helpful suggestions.  Let's face it. The link given above is sufficiently simple that it would take less time to try it than either one of us have spent in this thread. But, yeah, priorities vary, I get it.

cheerful24
Channel Surfer

Re: Cannot Connect to Wi-Fi for 2 Days.

Jump to solution

I've given up.  I have several Roku devices and have used them for years.  Now I'm switching to my old Apple TVs.  They still work fine.  Roku now sucks, I'm afraid. 

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Cannot Connect to Wi-Fi for 2 Days.

Jump to solution

@cheerful24 

Didn't see a response from you in the other threads where you posted.

As the others indicated, your devices (3700 and 3920) are 2.4ghz-only devices.  Have you verified that your Wireless Mode in your router is configured to b/g/n?

This had been the culprit of most of the cable ISP supplied routers.

Below are instructions for making changes to Xfinity/Comcast, Cox, and AT&T.  If not applicable post back with router model number and ISP.

Xfinity / Comcast → ( https://www.xfinity.com/support/articles/change-wifi-mode-admin-tool-xfinity-xfi ) with a walkthrough ( https://community.roku.com/t5/Network-Wireless-Wired-Connections/Error-014-30-stuck-for-three-days/m...)

Cox → (https://www.cox.com/residential/support/managing-your-in-home-network-with-my-wifi.html)

AT&T → (https://www.att.com/support/article/u-verse-high-speed-internet/KM1046172). You can select your appropriate router from the drop down menu.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos
cheerful24
Channel Surfer

Re: Cannot Connect to Wi-Fi for 2 Days.

Jump to solution

I have an Airport Time Capsule and am using Century Link.  As far as I can tell I can't change the configuration on the time capsule.  I switched to the router on my modem and that worked for a while.  I thought it had solved the problem, but suddenly that doesn't work either.  I have no problem streaming using Apple TV or on my iPads or on my Mac.  What is wrong with Roku?

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Cannot Connect to Wi-Fi for 2 Days.

Jump to solution

@cheerful24 

I am not familiar with the Airport Time Capsule, but here is forum link that explains how to make the setting changes to your 2.4 ghz band. (https://discussions.apple.com/thread/253036804)

As for the Centurylink, many times the opposite is needed and the legacy b needs to be disabled.  For CenturyLink you will want to try g/n wireless mode, and then under Advanced, try looking for an option (sometimes under LAN), that says "Allow Special Characters".  Alternatively, try using a password that does not use special characters if you are currently doing so.  These are the two known issues with CenturyLink and Roku.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos