Wi-Fi & connectivity

Having Roku connectivity problems? Get the help and troubleshooting tips you need for Roku wireless connection issues, ethernet connections, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't connect to internet - Roku Streaming Stick+ & TCL TV

I've been in my new home for over a year now and all of a sudden within the past couple weeks, both my Roku's, which are in different parts of the house and were working fine previously now have issues connecting (all other devices in the house, wireless and wired have no issues). The 55" TCL TV, either takes forever to connect, or you have to manually force it to connect to the WIFI network. The Stick+ in my bedroom, won't connect at all UNLESS I restart my router. Problem is that fix is only temporary; once I shut the Roku Stick+ off, next time I turn it on I have to restart my router again....every time. I've gone thru all the usual steps, all the way up to factory reset, disabling network pings, left Roku, modem & router unplugged for 10 minutes to completely shut all of them down, nothing works. Both the 2.4GHz & 5 GHz networks have the same result, and their channels should work (6 & 157 respectively). No new devices have come into the house recently either....at a loss. ISP is Optimum if that helps at all.

Community Streaming Expert

Re: Can't connect to internet - Roku Streaming Stick+ & TCL TV

If your router is supplied by Optimum it's possible they did some kind of update that's affecting things.  I've always found that Roku devices work best when as much as possible is static.  Don't use "Auto" as your Wi-Fi channel, use separate SSIDs for your 2.4 and 5 GHz networks (get rid of any "band steering" or whatever term the ISP/router manufacturer wants to use), and set up a DHCP reservation for each Roku device in the router so their IP addresses don't change.

For the Stick+, make sure you're using the supplied power adapter and not the TV's USB port.  You may want to try disabling "power saving" if it's available under Settings->System->Power.

For the TV, try to enable "Fast TV start" (or something like that).  I believe it's under Settings->System->Power.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos