Solving playback issues

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Youtube NO Playback, but can browse just fine.

Seems Youtube Channel is still messed up majorly.  I've seen people with other issues, but mine loads up youtube just fine.  I can select my account fine.  I can browse fine.  It's when I goto watch anything that there's a blackscreen issue with no video or audio.  sometimes it'll bring up internet connection (youtube channel only) and other times it'll just stay on the black screen for ages til I hit back on the remote, then it'll flip back for a moment and back to the blackscreen again, maknig me hit back button on the remote a 2nd time to get back to the browsing screen.  I do not know if this is related to the threat of people saying they couldn't load youtube channel at all or not as I load it just fine, but i tried changing from 1040p to 720p res on my roku device and tv. Tried system updates which found something for 2 channels. Tried uninstalling Youtube Channel, restarting the device, reinstalling Youtube Channel, Adding my account login again... none of which has seemed to resolve the issue of the blackscreen.  It's like it connects fine to browse for the youtube channel but then suddenly gets denied when it comes to playback for the Youtube Channel only.  Am in the USA, so no reason why it would be region blocked or such.  Any thoughts, ideas, means to fix without having to redo accounts for every channel would be very nice.  I like this channel as its one of the few free channels, and the one with the most possibilities of endless amounts of new content getting added.

0 Kudos
Level 7

Re: Youtube NO Playback, but can browse just fine.

Youtube on mine is bad right now too. It first started with no sound. I restarted it. After about 45 mins it kept skipping. Closed to restart and then just kept doing loading circle and wouldn’t open. It had trouble loading last week as wel.

0 Kudos