Solving playback issues

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
BobSmth49
Level 8

Re: Why do I have to unplug and replug my Roku premier each time I want to use it?

I went to the settings on the Samsung TV and checked the Eco Settings, the power saving was already turned off.  Then I went to the settings on the ROKU, settings/network, and  disabled the bandwidth saver function.  After all of that I went into ROKU, turned on YourTube TV (which I have on my other 3 tv's for streaming), then turned the tv off with the Roku remote.  When I returned a few hours later I got the same message, "Cable isn't connected".

0 Kudos
Streamer317
Level 13

Re: Why do I have to unplug and replug my Roku premier each time I want to use it?

Ok so when it says “cable isn’t connected” press the home button. Your Roku should wake up. Look in the advanced power settings on your TV. A lot of TVs will put a device to sleep when it’s inactive on a port. If you bring this Roku over to your other TV you don’t have the issue which means it’s your TV. I have a similar issue with my Roku stick and my older sharp TV. As soon as I turn the TV on there’s no signal. I press the home button to wake the Roku up. About 5-10 seconds later it’s working. After doing all this did you restart your Roku?

0 Kudos
makaiguy
Community Streaming Expert

Re: Why do I have to unplug and replug my Roku premier each time I want to use it?

Roku operating system version 10.5 added added a new "Power" item in the "Settings > System" menu for some of the latest Roku devices. The new "Auto power savings" item there will put your Roku device into a low power standby condition after a period of inactivity, such as when your tv has been turned off for a while.

Pressing a Roku control key on your Roku remote, like the Roku Home key (not Power, Volume, or Mute keys if you have them, which act on the TV, not the Roku), should bring the Roku out of standby and back to full operation. Pulling the power for a few seconds to restart the Roku will restore full operation as well.

If you have a "Settings > System > Power" menu item, deactivating any power saving options you find under "Auto power savings" will prevent your Roku from going into standby in the first place.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X
0 Kudos
BobSmth49
Level 8

Re: Why do I have to unplug and replug my Roku premier each time I want to use it?

Thanks Steamer317, pressing the Home button on the Roku remote did in fact wake the Roku up and it connected.  It was only off for about 20 mins however, so hope it holds true after a few hours.  Thanks for your guidance, much appreciated.

Streamer317
Level 13

Re: Why do I have to unplug and replug my Roku premier each time I want to use it?

@BobSmth49  Your welcome 

0 Kudos
JMP8866
Level 8

Re: Why do I have to unplug and replug my Roku premier each time I want to use it?

Okay, I figured this out purely by accident. Apparently the ROKU comes with an automatic 20 minute lockout that will activate if you don’t deactivate it while setting up your ROKU.  Go to Home>Settings>System>Power>Auto Power Savings. Then I click the box that says after 20 minutes of no interaction. I hope that works. It did for me. 


@NettaDenise wrote:

I just upgraded from a Roku 2 to a Roku premier. My until is set to HDMI 3. Every time I go to my Roku, it never loads automatically. I have to unplug it, then replug it for it to work. My Roku 2 never had that problem. Once I unplug it and replug it, it works perfectly. I don't understand why I have to do that at all. When I click on HDMI 3, it should be there. Any suggestions?


 

0 Kudos
JMP8866
Level 8

Re: Why do I have to unplug and replug my Roku premier each time I want to use it?

Settings>System>Power>Auto power savings>Click the box next to after 20 minutes of no interaction to disable it. 

JMP8866
Level 8

Re: Why do I have to unplug and replug my Roku premier each time I want to use it?

Settings>System>Power>Auto power savings>Click the box next to after 20 minutes of no interaction to disable it. 

0 Kudos
AvsGunnar
Community Streaming Expert

Re: Why do I have to unplug and replug my Roku premier each time I want to use it?

@JMP8866 

Good tip and appreciate the input, but I am thinking you must have one of the newer 4k/4k+ devices and not the Roku Premiere referenced in this thread.  (Settings/Systems/About to determine your model number).

This power savings feature capability was introduced with the newer Realtek chipsets of the newer line of Roku devices.

Although recommended to disable this feature as you have done (it is causing some issues, reportedly), pressing Home on the Roku Remote should wake the device up if you leave this setting Enabled.

 

 

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660x, Premiere+ 3921, Express 4k+ 3941

Re: Why do I have to unplug and replug my Roku premier each time I want to use it?

@AvsGunnar pressing Home on the remote worked for us. Thanks!