Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Weird Color Pixelation on Some Channels When Switching from Show to Commercial and Back

On certain broadcast channels on my Spectrum App, when the show goes to commercial the first few seconds will be weirdly pixelated with colors and pieces of the previous image.   Then it resolves until it's time to switch back to the show when it does this again.  It's more annoying but anything, TBH.

Internet speed: 140MBPS

Network Connection: Good

I've tried turning the auto-resolution switch on and off without success.

Any ideas?

0 Kudos
1 REPLY 1
RokuKariza-D
Retired Moderator

Re: Weird Color Pixelation on Some Channels When Switching from Show to Commercial and Back

Hi @LobstaJohnson

Thanks for the post.

Does the issue only occur within Spectrum? Have you checked other apps installed on your Roku device if the same problem happens?

Moreover, removing the channel and then reinstalling it may help. To ensure the process is successful, restart your device before adding the channel back in. We would recommend doing this from the Settings menu by navigating to Settings > System > Power (If you do not see a Power submenu, skip to the next step.) > System restart.

For detailed instructions, refer to this Support link: How do I resolve channel playback issues?

Keep us updated!


All the best,
Kariza

Kariza D.
Roku Forum Moderator
0 Kudos