Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Channel Surfer

Ultra (4800X) freezing on Roku Channel and Plex when skipping/play

I recently purchased a new Ultra and saw freezing issues with Plex.  Then I see the same issue using the Roku Channel.

Freezing usually occurs after skipping or fast forwarding and then pressing play.   I've also seen this in the middle of regular play a few times.

In the past, if I had a rare issue, I'd hit the Home button 4-6 times to force reboot.  I've tried that, but no luck, so I pull the unplug/plug power to get it going again.  Sometimes if I wait long enough, it finally figures that there something wrong and reboots itself.

I've been using Plex, Roku channels without issue with the older Ultra, RokuTv and Roku 3.  Been a long time Roku owner since N1000.

Is this a defective device?

Roku Ultra 4800X
10.0.0 4209-C2
Wired (1Gbps)
200Mpbs internet

Retired Moderator

Re: Ultra (4800X) freezing on Roku Channel and Plex when skipping/play


Thanks for the post.

Try removing the channel from the Roku home screen by navigating to the channel tile, pressing the * key on your remote and choosing 'Remove channel'. Then restart your device from Settings>System>System restart. Once your player starts up again, add the channel back once more.

Does this clear up the issue you are seeing? Please keep us posted what you find out.



Danny R.
Roku Community Moderator
0 Kudos

roku 4800x will not play video from Plex app

I had an older Roku 4 and everything was working well. the Roku 4 died and I needed to replace it, I bought a Roku ultra 4800x. several server updates happened during the time I installed the new Roku and by the time I actually tried to use it.

Nothing plays. no video from any source using the Plex app. it either gets stuck on 99% buffer or I just get a blank screen. I know this sounds like a Roku setting but for the life of me I can not figure out the problem. I have tried forcing the Roku to use 1080p and see if plex would work with that but that was also a no-go. Just to make sure it was not a server issue I am able to play movies on a PC and my phone streaming from the local server. if anyone else is having this problem or knows how to fix this I would be greatly appreciative.  I have tried removing the app and re-installing it with no joy.

The next day 11/07/2021
Grabbed an older Roku from a different TV and plugged it into the one from above, it worked, it is definitely a Roku 4800 issue, I will contact Roku and see about it. again if someone has seen this problem please let me know.

Channel Surfer

Re: Ultra (4800X) freezing on Roku Channel and Plex when skipping/play

Sorry for the delay in answering, life gets in the way :).    While it did improve most of the freezing, it still will freeze for a few seconds before continuing when fast forward/rewind, etc.   But on less occasions, it will freeze up the Roku completely and eventually it will reboot, unlike before where is just sat there frozen.   There's definitely something wrong with my new Roku, not sure if this is just a fluke or a overall quality/design issue with the new Roku Ultra.   

I got side-tracked and didn't act...I believe I'm past the return/replacement date for this, so looks like I'm out of luck.  Need to look at the Nvidia Shield.

0 Kudos