Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Roku not working for any apps

2 days now and I can't watch anything on roku stick at all. Every TV app, my YouTubetv, sling, hulu, you can't get a live person either with roku. They refuse to refund the money at Walmart. Guess I'm getting apple TV and filing a complaint with business bureau. They refuse to even address this issue and we haven't had ours long at all. I knew I shouldn't have bought this for one of our tvs.

0 Kudos
Community Streaming Expert

Re: Roku not working for any apps


Might your router be one supplied by your internet provider? If so, your problem may have been caused by a recent update to your router. This has been reported lately with equipment from Xfinity and Cox, but there may be others.

Affected users report the router configuration needs to be switched from g/n security back to b/g/n. If you don't have access to your router's control panel you may have to have your internet provider do it for you.

Roku Community Streaming Expert
I am not a Roku employee, only a user like you.  Please, no support questions via private message -- post them publicly to the Community where others may benefit as well.
If this post solves your problem please help others find this answer by clicking "Accept as Solution.".

Streaming Stick 4K+ 3821 | Streaming Stick+ 3810 | TCL Roku TV 43S245/C107X
0 Kudos

Re: Roku not working for any apps

My ok button is not working I changed the batteries it is letting me scroll through the channels but I can’t pick anything I have on my tv. I was just using my older model roku on my older tv in my living room it was fine. Had family over watched Cruella on Disney plus no issues come up to my room I have a newer tv and a upgraded roku not allowing me to press ok. Tried resetting the tv and remote nothing it’s the same thing allowing me to scroll through but not select anything. I pay for many streaming services through roku and I am not generally impressed right now. First time I have had an issue with this. Shut off WiFi in my whole house to see it that’s why press on app after resetting its legit lag loading. Not catching anything. Pretty pissed off 

0 Kudos

Re: Roku not working for any apps

I am having the exact same issues since Thursday as well. Newer Roku works fine in bedroom but older version isn’t cooperating. Thursday evening when I tried selecting any app from the home menu it showed “loading” and never opened the selected app. Now it won’t even let me select an app. I can navigate the screen but not select anything. Zero support sucks as a business model for a technology company. 

0 Kudos
Roku Guru

Re: Roku not working for any apps

Hi @Kushahontas @jboswell

Thanks for letting us know about the issue you're experiencing.

Have you tried replacing the batteries on your remote? You can also try the troubleshooting steps available in this Support link: How to resolve issues with your Roku® simple remote or Roku voice remote

Please keep us posted on how it goes!

All the best,

Kariza D.
Roku Forum Moderator
0 Kudos