Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
slider9499
Channel Surfer

Re: Roku device freezes and needs to restart

I have nothing but problems with Roku. It constantly freezes, locks up, apps don't work...it really is a piece of junk. My wifi is awesome.  I get speeds close to 900 mbps and Roku keeps giving me messages stating my connection is slow. I cannot tell you how many times I have to restart my device - at least 5 times a week

RokuDanny-R
Retired Moderator

Re: Roku device freezes and needs to restart

@slider9499

Thanks for the post.

Can you please provide more details regarding the issue you are experiencing? What Roku model device are you using? How are you powering the device? What channels are you seeing an issue with? What troubleshooting steps have you already tried to resolve the issue?

With more specific information, we will be able to assist you further.


Thanks,
Danny

Danny R.
Roku Community Moderator
0 Kudos
TwinDad79
Reel Rookie

Re: Roku device freezes and needs to restart

Danny - this is happening to me every 2 days days or so on a new 4K stick.

Any clue??

https://www.dropbox.com/s/zymjogcmhajgy5n/IMG_0544.MOV?dl=0 

0 Kudos
RokuKariza-D
Roku Guru

Re: Roku device freezes and needs to restart

Hey @TwinDad79

Thanks for reaching out!

For starters, have you tried the troubleshooting steps available in this Support link: How to resolve issues with your Roku® simple remote or Roku voice remote? Try giving that a shot. It might be an issue with the remote. 

Let us know how it goes.


All the best,
Kariza

Kariza D.
Roku Forum Moderator
TwinDad79
Reel Rookie

Re: Roku device freezes and needs to restart

Thanks for the prompt answer @RokuKariza-D ! 

I have a hunch it's the controller, yes. It's been freezing daily now and when I tried the phone app, it works just fine. 

A had done some of these steps but will try again. Is there any chance this could be hardware and the controller is actuallly defective? I still have a return window, and might try that route soon.

Cheers

0 Kudos
RokuKariza-D
Roku Guru

Re: Roku device freezes and needs to restart

@TwinDad79

I apologize for the delay in response.

If by chance the steps in the FAQ didn't resolve the issue you're experiencing, reply here with the serial number of your Roku device associated with the affected remote. It can be viewed in Settings > System > About

We can assist you further from there.


All the best,
Kariza

Kariza D.
Roku Forum Moderator
0 Kudos
TwinDad79
Reel Rookie

Re: Roku device freezes and needs to restart

Yeah @RokuKariza-D , unfortunately, no luck. Even factory reset the device yesterday (or 2 days ago), logged in to all the apps, and paired the controller again. This morning, when my kids tried to use it, no luck, the controller was unresponsive. And when using the app on my phone, it worked, so it's definitely the controller. Pressed that power (?) button on the stick, restarted it a repaired the controller, so it's working again - but will likely fail again soon.

  • Model: 3820X - Streaming Stick 4K
  • Serial Number: X01700LCMK0T
  • Software version: 10.5.1 - build 4059-CU
  • Device ID: S08Y418CMKOT

 

0 Kudos
TwinDad79
Reel Rookie

Re: Roku device freezes and needs to restart

@RokuKariza-D Just one more piece of info: the on/off and TV volume controls on the voice remote still work, so it's only the pairing to the actual stick that's failing daily. 

0 Kudos
RokuKariza-D
Roku Guru

Re: Roku device freezes and needs to restart

@TwinDad79

Thanks for the prompt reply..

I have passed along your information and concern to our Support team. They will follow up and further assist you through email.


All the best,
Kariza

Kariza D.
Roku Forum Moderator
0 Kudos
Mark26
Reel Rookie

Roku device freezes solution?

Mine started doing a similar thing. The only thing that seemed to work was slightly unplugging the HDMI cable then plugging it back in. What I found to actually solve the problem long term was go into settings and change the picture from 1080P to 720P. Bingo the problem went away.

0 Kudos