Solving playback issues

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7

Rewind & FF skip to previous or next program

I have an old Roku 3, and a remote that seems to be a gaming remote (that’s what it says when I go into settings). I was super excited to find the Starlost channel, so I added it, and started to watch the first episode. My husband interrupted my watching to tell me something, so I hit rewind on the remote to back up a little. But I nstead of rewinding within the program, I was taken to a promo spot for the show that precedes the first episode! I tried a few different things to test out the remote, and it behaves as reported in my subject line above: FF takes me to the next show on the channel: Rewind takes me to the previous one. I tried the arrow buttons as well: left, right, and down so nothing, while up takes me to the Home Screen. The asterisk button also does nothing. I even re-set my box and the remote, and it still doesn’t work!

This is a very old box, but it seems to work fine. I have no problem buying another remote if this one is missing this function, or has stopped working, but I have no idea which Roku remote would even be compatible with such an old box! I don’t watch much on Roku, but I’ve always been able to use those functions (although they are a bit clunky compared to the functionality of my FiOS remote). Does anyone have any ideas, advice, or other thoughts on this? Thanks in advance.

0 Kudos