Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Andy01
Newbie

Re: Roku channel Canada not playing movies

Same with me. Amazing. No answer sonce 2019. That problem can't be that uncommon. ANYBODY CAN HELP US???? 

0 Kudos
3 REPLIES 3
RokuMary-F
Community Moderator
Community Moderator

Re: Roku channel Canada not playing movies

Hi @Andy01,

Welcome to the Roku Community!

I'd be happy to take a closer look to see how we can help get you up and running.
A few questions here to better understand what you're experiencing: 
1. Are you using a Roku TV or a Roku device?
2. Does the issue only occur on a specific channel or all channels on your Roku device?
3. Can you please cite specific content title examples that you have tried to play on The Roku Channel that is experiencing an issue?
4. Are you receiving error messages or codes when accessing the channel?
5. What troubleshooting steps have you taken so far to try to resolve the issue?
6. What are you seeing on screen? Can you provide a screenshot of the issue you are experiencing?
With more information, we will be able to assist you further.
 

Best regards,
Mary

Mary F.
Roku Community Moderator
0 Kudos
Yginc
Newbie

Re: Roku channel Canada not playing movies

I recently subscribed to the Roku Channel, and movies will not play. Loading message briefly comes on followed by play message which flashes then disappears. I have tried resetting then rebooting but nothing works. I am in Canada

 

0 Kudos
RokuMary-F
Community Moderator
Community Moderator

Re: Roku channel Canada not playing movies

Hi @Yginc,

Thanks for posting in the Roku Community!

I'd be happy to look closely to see how we can help get you up and running.

What was the error message when attempting to stream the channel? Do you observe this behavior while using any other channel(s) on your device? Have you tried removing the channel, restarting your device from Settings>System>Power>System restart (If you do not see a Power submenu, skip to the next step), then once it loads up again, adding the channel back once more to see if that clears things up? In addition, what Roku model device are you using?

Once we have this information, we will be able to assist you further.


Best regards,

Mary

Mary F.
Roku Community Moderator
0 Kudos