Solving playback issues

Help with audio & video playback issues, TV display type recognition & compatibility, HDCP messages, troubleshooting playback errors, advertisements, and resolving power issues.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Its_me_again
Level 7

Re: Only sound and no picture

I have the same issue. 

0 Kudos
Flummoxed
Level 7

Re: Only sound and no picture

I am having a similar issue for al apps: all menus, etc. appear onscreen and navigation works fine, but when I click to play a show, there is either sound and no picture or an error message, depending on the app. Oddly, Amazon worked when I tied it an hour ago, and when I checked it just now, it had no picture and no sound. In all cases, closed captioning and other screen messages do show up.

I tried all the things recommended in these threads -- restarting, checking for updates, unplugging everything, changing aspect ratio and other settings, etc. -- but nothing has worked. 

I just replaced my wifi network. I contacted TP-Link to see if the bandwidth or security settings could be choking the signal. They said no.

Please help! 

(I have 2 Roku Express, I'm not sure of the exact model -- the problem is happening with both of them)

0 Kudos
trink56
Level 8

Re: Only sound and no picture

Hi Roku Folks:

Our Roku home screen shows up just as it should, The home screen of each streaming service shows up just as it should. When we pick a show, the sound and closed captioning are there just as they should be and, if we fast-forward or rewind we can see the thumbnail images. BUT the picture is not there -- black screen. The problem started after we watched a show (all fine) and at the start of another. Same situation for all streaming services. We have done a system re-start, unplugged and re-plugged the roku and un-plugged and re-plugged the router --- no joy.

Model #4800X

Ideas and help appreciated!

 

Thanks/jim

user1369
Level 8

Re: Only sound and no picture

Danny,

I just started having the same issue. Is this a known issue with Roku (maybe something happened during a system update)? Is there a fix coming for this? At this time I can't watch anything on any channel on my Roku. Please let me know what info you need from regarding this. I haven't had my Roku that long so it should be covered under warranty still.

0 Kudos
aaustin912
Level 8

Re: Only sound and no picture

Here’s what I’ve discovered after hours of research. The latest update did something with older TVs. My stick works fine on my new tv and mostly fine on my older tv. My express will not work on older tv, but works just fine on my newer tv. Seems like now if your tv doesn’t have 4k capability, the express won’t work 

0 Kudos
Joecon
Level 7

Re: Only sound and no picture

This is happening to hundred/thousands of customers. It began for all of us at the same time. The problem is on YOUR or PARAMOUNT+ end. Please fix this.

steve188
Level 7

Re: Only sound and no picture

Same issue with PARAMOUNT+  Started after the last ROKU update was installed.  Good sound, ads and intro play well, but when the shows start, there is no picture.

0 Kudos
user1369
Level 8

Re: Only sound and no picture

Yep. We had it happen this morning when trying to play Paramount+. Tried Netflix, one show played and then it stopped. Tried Hulu, same thing happened. Tried all the normal stuff: reset the Roku, uninstall and install the channel, checked HDMI cable and cable hookup, etc. They really need to fix this.

0 Kudos
Joecon
Level 7

Re: Only sound and no picture

What’s really annoying is that NO ONE is getting a response from ROKU or Paramount+

The problem lies with one of those two, NOT the thousands of us that it is happening to.

How about a Frigging Answer???

0 Kudos
BBScout
Level 8

Re: Only sound and no picture

Roku apps are not working on any of my four devices.  I have unplugged and rebooted. I have checked the internet.  No Go!!!

Roku FIX YOUR PROBLEM! This is not a user error by a system wide issue.  FIX IT!!!

0 Kudos