Solving playback issues

Find troubleshooting tips and resources for Roku playback speed issues, HDCP messages, power issues, and more. Join the community discussion for assistance.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

New Streaming Stick 4k is missing "audio mode" menu option


After 5 years of almost zero headaches with my roku streaming stick I decided to update to a new one because the remote control was starting to malfunction and annoying me.

Everything seemed fine, but when I tried to setup the audio setting for my old LG tv, that support dolby digital just fine, I've noticed that the "Audio Mode" menu option is missing in the new device.

When testing using plex or jellyfin to stream ac3 5.1 audio, I ended up having no sound, and I'm pretty sure that is related to this.  So plugged the old roku back in, and it worked just fine. The options I have there are also set to Dolby, and I expected to set the audio mode to dolby to in order to avoid this.

Is there a reason for this option to no be present in the new streaming stick? Is there any way for me to set the audio mode at all?

The old Roku SS
3600X - Roku Stick
11.5.0 • build 4312-24

The new Roku SS4k
Model 3820CA - Streaming Stick 4K
Serial number X01700H36VLR
Software version 11,5.0 • build 4235-CU

0 Kudos