Roku setup

From linking a device to your account to adding channels, find Roku setup troubleshooting help and activation support from our community support forum.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
userrob
Channel Surfer

Ultra worked for only 1 day/24 hours. Next day "no signal." Can't get past the Set-up mode!

Brand new purchased Feb 3 2022 from Costco. The first time I connected it to my Sharp Aquos TV of 2010 it didn't connect to a feature offered by my Paramount+ subscription. So 2 days ago, Feb 9, I factory reset the Ultra and started back at square 1. I got it to work including the one Paramount+ feature I wanted, HOWEVER, I couldn't turn the TV off or on using the Roku remote. I can live with that. So the 10th I tried to use the Ultra but it took turning my TV off and back on to get the HDMI signal, but I did and I watched my program for the hour.

I tried again this AM, the 11th, and failed TOTALLY to ever get any HDMI signal. I turned my TV on and off multiple times, I tried switching back and forth between TV and HDMI, and I tried pressing and holding several of the remote's keys. I even tried re-pairing the remote. Total failure. And yes I do know WHICH HDMI input I used.

I'm wondering if the HDMI signal might take better if I were to add signal booster like the ExtendTech signal booster? or

Would the Roku Streaming Stick 4k be better at receiving the HDMI signal. That Costco purchase included both items.

0 Kudos
6 REPLIES 6
renojim
Community Streaming Expert

Re: Ultra worked for only 1 day/24 hours. Next day "no signal." Can't get past the Set-up

Did you try pressing any buttons on the Roku remote?  Look for a "power saving" option under Settings->System->Power and disable it or press Home on your Roku remote to wake the Ultra from power saving mode.

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos
userrob
Channel Surfer

Re: Ultra worked for only 1 day/24 hours. Next day "no signal." Can't get past the Set-up

Thank you for trying to help but I did answer your questions in my original post. Power saver is OFF.

0 Kudos
Strega
Roku Guru

Re: Ultra worked for only 1 day/24 hours. Next day "no signal." Can't get past the Set-up

Is your setup unusual or very far away?  I'm just wondering since the reference to an HDMI signal booster and the question about another model being better at receiving HDMI makes me think that you think your system is unusual.  Otherwise, sometimes HDMI issues can be solved by something as simple as reseating the connectors on both ends or using a different cable.

Since you already have another one, trying that is a good debugging tool too.  If something turns out to have died, Costco is good about returns/exchanges.

0 Kudos
userrob
Channel Surfer

Re: Ultra worked for only 1 day/24 hours. Next day "no signal." Can't get past the Set-up

Thank you. Actually my home is small, the router is the most powerful I could buy meant for multiple gamers, which I am not. The router might be 40 ft away with only a couple of corners to round. I was simply wondering if a booster might help. I rebooted the whole thing again and again it worked the next day. Now I will wait for the 2nd day to arrive...

Day 4 has passed and it still works. I think the thing that changed the outcome is unchecking the power saver. Perhaps it exists for cell phones, notebooks, and other battery powered equipment, but it is NOT needed nor helpful when Roku is connected to electrical powered equipment such as TVs. Given TVs are the primary target equipment I think this item should NOT be checked by default. 

0 Kudos
Strega
Roku Guru

Re: Ultra worked for only 1 day/24 hours. Next day "no signal." Can't get past the Set-up

Oh, I thought you were referring to boosting the HDMI signal.  This is usually only required for extremely long HDMI runs. But you were referring to Wi-Fi boosting?  It doesn't sound like a Wi-Fi issue to me.

0 Kudos
RokuDanny-R
Retired Moderator

Re: Ultra worked for only 1 day/24 hours. Next day "no signal." Can't get past the Set-up

@userrob

Thanks for the posts.

If you are still unable to resolve the issue, can you please provide the serial number/device ID on your Roku device? I'll be able to assist you further from there.

 

Thanks,
Danny

Danny R.
Roku Community Moderator
0 Kudos
Need Assistance?
Welcome to the Roku Community! Feel free to search our Community for answers or post your question to get help.

Become a Roku Streaming Expert!

Share your expertise, help fellow streamers, and unlock exclusive rewards as part of the Roku Community. Learn more.