Roku setup

From linking a device to your account to adding channels, find Roku setup troubleshooting help and activation support from our community support forum.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
cloudz539
Newbie

This USB device requires more power" message when no USB plugged in

Minusing the exact same thing but when I click close it only will appears 9 seconds later

Labels (1)
0 Kudos
2 REPLIES 2
RokuElmer-H
Community Moderator
Community Moderator

Re: "This USB device requires more power" message when no USB plugged in

Hi, @cloudz539!

Welcome, and thank you for reporting this issue to the Roku Community!

We will work with you to know what went wrong so we can assist you further and fix the issue.

Could you confirm if you've encountered this error message for the first time, or if it appeared after activating the device recently?

If your Roku device is getting an error message of "This USB device requires more power. Use a power adapter if available", it might be due to insufficient power supply. This occurs when the USB drive requires more power than the Roku device can provide. Here's what you can do to address this:

  1. Check for External Power Adapter: If your USB drive comes with an external power adapter, connect it to a power outlet. This should provide the necessary power for proper detection.

  2. Use a Powered USB Hub: If your USB drive doesn't have an external power adapter, you'll need to utilize a powered USB hub. This device will supply additional power to ensure proper functioning.

For detailed instructions and further assistance, please refer to our support page: Why does my Roku streaming device not recognize my external USB drive?

We appreciate your patience and cooperation as we work towards a resolution. If you have any additional questions or concerns, feel free to reach out. Your satisfaction is our priority.


Best regards,
Elmer

Elmer H.
Roku Community Moderator
TreDay
Newbie

Re: This USB device requires more power" message when no USB plugged in

I’m having the same problem as of today and have tried everything. Different outlets. Factory reset. Nothing fixed it. I don’t have anything plugged in to the USB. So frustrating. I can’t watch Tv. It comes back immediately when I hit the close button. 

“This USB device requires more power. Use power adapter if available"

0 Kudos