Roku setup

From linking a device to your account to adding channels, find Roku setup troubleshooting help and activation support from our community support forum.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Channel Surfer

Can't Get 3930 To Connect

I have a 3700 and a 3900.  They connect fine.  (I have two WiFi access points to choose from.)

Back in November I decided to pickup Walmart's $17 Black Friday special.  It was a 3930.  It would not connect to either of my WiFi points.  It's not a signal strength issue as I did try testing it inches away.  I tried resetting the type of security on the WiFi and also tried it with security dropped entirely.  I see the signals on the listing; select one; put in the password (or none) and never attain that first step in the connection.

I gave up and returned it.

I then purchased what I thought might be another model, the $29 one.  Nope.  Same model 3930.  Apparently the extra $12 just gets you a power cube.  Same exact issues.   I returned it as well.

Recently I saw the upgrade offer in the Roku account ($20).  Figured I'd give it a shot.  Turns out to be the same model 3930.  Same issues.  It will not get passed that first step of connecting to the router. 

(I know one definition of insanity is trying the same thing over and over expecting different results.  In my defense I had no way of know that it would always be the same model I was getting.  Part of Roku's business model is to force people to upgrade by not making new channels available on older models so you'd think they'd be on to a new model by's been a whole 3 months!)

I have no idea what the issue is.  My WiFi works with my existing two Rokus and that of my GF who sometimes brings her own.  Not to mention laptops, iPhones, etc.

One WiFi is an old MS MN700.  The other is a Belkin N150 just a couple years old.  What's going on?  Is there some security level required?  Is there some sort of security the new Rokus demand that is not offered by my existing routers.

I've tried WEP64, WEP128, WPA+PSK / WPA2+PSK, plus no security (as a test).

I fear what will happen on my existing, working devices if they ever update to similar software.  And I have good reason to be fearful.  When I got the 3700 it worked fine.  One day it was offline and demanded a firmware update.  After updating it would no longer connect.  It was still fairly new and Roku replaced it.  The new one connected fine, and said "let me check for an update."  After the update it would no longer connect.  Roku finally told me I need a new router.  I got the Belkin.  Curiously, that 3700 now does in fact connect to either router.

Any ideas?  Return this one too?  Buy yet another router?   Say screw it and buy a Firestick?

0 Kudos
Roku Guru

Re: Can't Get 3930 To Connect

The "newest" Belkin N150 is a 9 year old model (released in 2012) - you may have purchased it "a couple of years ago", but thats how old its tech is.  Remember, we are at "AX" (WiFi6) and "E" (WiFi6E - 6Ghz spectrum) now.

So yes, you might consider getting a newer router/gateway, or at least make sure you have the latest firmware for that one, and verify any compatibility settings (try disabling/enabling any legacy "B" related settings).

And while Roku does want to sell you newer models/get you to upgrade, its not because they arent making apps available for older models (thats a choice/decision/limitation imposed by the app developers), but because you WILL have access to newer apps/more content at greater speed/ease of usage, and therefore are likely to use it more thus watch more ads thus generate more revenue for Roku.

Roku's firmware updates have always had issues, and those over the last year or two have been particularly bad overall, especially as it relates to the cheaper models with 2.4Ghz only capability and broken/buggy WiFi drivers - so it could very well be a Roku firmware/driver issue, and you are wise to be wary, considering your past experience, and especially since Roku doesnt have an official or reliable update reversion process.

You might try connecting it to a phone HotSpot or a neighbors/GF's WiFi - at least for the initial activation/update process, and then seeing how it behaves connecting to your (firmware updated/settings changed/tested) WiFi.

And you should get a FireTV stick - its best to have multiple streaming platforms available for all sorts of reasons, including connection issues and bad firmware updates - and its not expensive at all to do so.


0 Kudos
Channel Surfer

Re: Can't Get 3930 To Connect

I stand by my opinion of Roku's business model.  Yes, things will work better on a newer device with faster processing which enables more sophisticated compression and so forth.  But at its heart Roku is a video delivery system and there is no reason a device just a few years old cannot get the latest channels. Yes, it may be up to the app makers but that still the result of negotiations with Roku.  Apple TV+ will work on 3900 not the 3700.   But Apple's screener channel (for industry and press) is available for both.  Which means their programmers have done the work.  But Roku didn't want it for everyone and Apple didn't insist hard enough on it.  I was very surprised that HBO Max works on both.  Part of the intense negotiations no doubt.  Just look at the Wiki article how many models they've gone through over their existence.

If my issue is the router (again) then I will add another assertion:  Inept coding.  It should either work, or not show the WiFi as available or tell the user what the issue was.

Yesterday, I did exactly what you suggest in your post.  I took it to try to get online elsewhere.  It connected, said it would check for an update, the update downloaded (no noticeable issue with the download).  When it rebooted, I got the bouncy letter animation (BLA), then black, then BLA, then black and so forth.  After about ten rounds I power cycled.  Same thing.  Pressed the reset button.  Same thing.  Roku's updated bricked it.  Inept coding.  It should have done a better verification of the integrity of the update before applying.

I have the RMA...back it goes. 

Thanks for your advice.  Will see if a new one survives an update and if that fixes the initial issue.  If not I will look into yet another router.  Or a Firestick.

0 Kudos