Roku setup

From linking a device to your account to adding channels, find Roku setup troubleshooting help and activation support from our community support forum.
Showing results for 
Show  only  | Search instead for 
Did you mean: 

After doing a factory reset my Roku now doesn't work.

After doing a factory reset my Roku is now stuck on the "Let's get started" screen and won't let me choose a language. I have tried pairing my remote to the Roku again and nothing is working. I have tried unplugging it and plugging it back in. I have tried new batteries in my remote. I can't get past this screen.  

0 Kudos
Retired Moderator

Re: After doing a factory reset my Roku now doesn't work.


Thanks for the post.

When you did a factory reset, did you make sure to remove the batteries out of your remote? Did you make sure to follow the instructions on screen when it asks you to pair the remote?

For troubleshooting steps regarding pairing your remote, visit our Support page here: Fix your remote

If you are still experiencing an issue, can you please provide the serial number/device ID on your Roku device? I'll be able to assist you further from there.



Danny R.
Roku Community Moderator
0 Kudos