Roku mobile app

Discover troubleshooting and helpful tips for the Roku mobile app. Learn how to use the Roku remote on your phone, add channels, privately listen, and more.
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 8

App will not see any devices in room

I have the most recent Roku app on my phone.  My phone is attached to my current home network.  I have 2 different Roku devices, a older Roku stick and a newer Roku Express 4K+. Neither appears in the Devices section of the app.

I don't have the Roku remote that goes with the Roku stick, so I can't access the device to get the IP address manually.  [My ISP gave me the newest router that restricts user from browsing the NAT list of IP addresses handed out any more.]  I can't tell from the Home screen if it's connected to the network or not.

I do have the remote for the Roku Express 4K+, and the device works fine.  It just isn't seen my the Roku app on my phone.

I've tried restarting and rebooting everything - any other suggestions?

0 Kudos
Community Streaming Expert

Re: App will not see any devices in room


Since you mentioned that your router is restricting IP discovery, try looking for a setting in your router (or mobile app for your router if applicable) for a setting called "AP isolation" and disable it.  Normally located under Advanced or Professional (Asus) settings.

The above setting, when enabled, will prevent network connected devices from discovering and communicating with each other. (ie. mobile apps and Roku).

In addition, check your Roku settings and verify that your Roku device allows mobile app access.

Settings/System/Advanced System Settings/Control by mobile apps/Network Access/[set to Default or Permissive].

Feel free to post back with router model number if still having issues.

Roku Community Streaming Expert
Just another Roku user... I am not a Roku employee.
Insignia RokuTV, Ultra 4660, Premiere+ 3921, Express 4k+ 3941, Streambar 9102

0 Kudos
Level 9

Roku Mobile App can't see device

I had a problem with the Roku Android App not being able to detect my TCL Roku TV. I went through all of the solutions posted, and none worked. But when I went to Settings / Network / Check Connection on my Roku TV, after the check my Roku TV appeared in the Roku app. Hopefully this helps some users out there who have been frustrated like I have been. I posted this because all of the other posts regarding this have been locked.