Roku Mobile App

Help with the Roku Mobile app on Android and iOS, adding channels, using remote control functionality, playing content from The Roku Channel, using Play on Roku, mobile private listening, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 8

Turn off Eco Mode

Jump to solution
When I try to access the TV from the mobile app, a message pops up stating that the TV must be in Eco mode. Wake TV or Switch Devices,
TV is on, playing show on Netflix, during this message.
I have auto-off after 15 min UNchecked.
How can Eco mode be turned off?
Labels (1)
2 Solutions

Accepted Solutions
Highlighted

Re: Turn off Eco Mode

Jump to solution

I found that it was caused by my tv being connect wired with a lan cable and my phone in wifi. They have to be on the same network. Apparently on the same wifi is what they actually meant.

View solution in original post

0 Kudos
Highlighted
Level 7

Re: Turn off Eco Mode

Jump to solution

Depending upon which model of TCL Roku you have your "eco" (eco friendly) mode settings may be found in more than one way.  There are your Roku settings which are found by just going to settings and (as prior contributors have said) switching off (unchecking) the low power mode settings...BUT. (this is what worked for me) you also need to change the low power picture setting by clicking on a channel and watching something and then (using your regular manual remote) pressing the star or options button and finding the picture settings there. As soon as I changed the picture setting to normal instead of a low power picture setting the Roku app started working. Hope this helps!

View solution in original post

9 Replies
Highlighted
Level 7

Re: Turn off Eco Mode

Jump to solution
Did you find any help with this? I am having same problem with my app. I searched everywhere, but couldn’t find a way to fix the problem!
0 Kudos
Highlighted
Level 8

Re: Turn off Eco Mode

Jump to solution
Nope, I’ve also gone into the App Store to read the reviews and it seems to be a very common problem. It’s a serious issue with app itself. I have another Roku and it never had this issue (recent updates may have created a problem).
Highlighted
Level 8

Re: Turn off Eco Mode

Jump to solution
So I’ve found a solution for mine. I switched devices from one TV to the other and back again.
I am also logged out of my account within the app.
I can now access both TVs with the app.
0 Kudos
Highlighted

Re: Turn off Eco Mode

Jump to solution

I found that it was caused by my tv being connect wired with a lan cable and my phone in wifi. They have to be on the same network. Apparently on the same wifi is what they actually meant.

View solution in original post

0 Kudos
Highlighted
Level 8

Re: Turn off Eco Mode

Jump to solution

Must be a glitch with the app. Both of my devices were connected to wifi - same network. But if someone else has the issue they now have a variety of things to try lol

0 Kudos
Highlighted

Re: Turn off Eco Mode

Jump to solution

Definitely was that for me. I switched back to wired and immediately it stopped working. Switch back again and working again. Maybe yours just needed a reset to get ip addresses right or something. Glad we both got it fixed!

Highlighted
Level 7

Re: Turn off Eco Mode

Jump to solution

Same thing happens to me, no solution. Please help

0 Kudos
Level 8

Re: Turn off Eco Mode

Jump to solution

Try logging out of app on phone & switch devices

Make sure both devices connected to the same wifi 

Factory reset TV (last resort)

 

0 Kudos
Highlighted
Level 7

Re: Turn off Eco Mode

Jump to solution

Depending upon which model of TCL Roku you have your "eco" (eco friendly) mode settings may be found in more than one way.  There are your Roku settings which are found by just going to settings and (as prior contributors have said) switching off (unchecking) the low power mode settings...BUT. (this is what worked for me) you also need to change the low power picture setting by clicking on a channel and watching something and then (using your regular manual remote) pressing the star or options button and finding the picture settings there. As soon as I changed the picture setting to normal instead of a low power picture setting the Roku app started working. Hope this helps!

View solution in original post