Roku Mobile App

Help with the Roku Mobile app on Android and iOS, adding channels, using remote control functionality, playing content from The Roku Channel, using Play on Roku, mobile private listening, and more.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Roku app unable to see my TV

Jump to solution

After going through all the steps in the support article for the app ( https://support.roku.com/en-ca/article/115001480188-why-does-the-roku-mobile-app-not-see-my-roku-str... ) the Roku App is still unable to connect to my TV. 

- The network is exactly the same,

- It is on a private network,

- My router is not in AP mode,

- The signal strength is good,

- I've restarted both my devices,

- The TV is on Default in the Network access,

- My phone is not on a VPN,

- I've tried connecting manually and it still fails

I'm kinda hoping there is something I could have forgot, maybe some special setting I could change in my router?

Thanks!

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
Highlighted

Re: Roku app unable to see my TV

Jump to solution

In fact, I fixed it by restarting my router!

View solution in original post

0 Kudos
3 Replies
Highlighted
Level 7

Re: Roku app unable to see my TV

Jump to solution

Sorry to say I have the same situation, except I have two TCL series 4 Roku TVs. One is 32" the other is a new 65". The 32" still works fine with the Roku app. The 65" worked fine for one week with the app. Then the 65" stopped working with the app couple days ago. I applied and verified all the same solutions and settings, plus restored the 65" to factory settings and started from scratch. Just wanted you to know you're not alone.  

0 Kudos
Highlighted

Re: Roku app unable to see my TV

Jump to solution

In fact, I fixed it by restarting my router!

View solution in original post

0 Kudos
Highlighted
Level 7

Re: Roku app unable to see my TV

Jump to solution

Many thanks. I thought I'd rebooted the router already, but thought I'd try again and leave it off for a couple minutes. That did the trick!

0 Kudos