Roku Mobile App

Help with the Roku Mobile app on Android and iOS, adding channels, using remote control functionality, playing content from The Roku Channel, using Play on Roku, mobile private listening, and more.
cancel
Showing results for 
Search instead for 
Did you mean: 
morsoft
Level 7

Roku App - no devices

Some while ago my Roku 3 stopped working with the Roku remote app, both on IOS and android. When I try to connect I get "no devices" found and the same happens when I try to connect manually. Needless to say I have read the standard Roku faq for this problem and all is correct. The Roku is on the same network as the iPad and android devices and has an IP address of 192.168.1.x. I have tried 3 different routers and have switched off or reset the Roku/Router/Remove devices in every combination possible but without success.
Some 3rd party apps work ok with a manual connection but none seem to find the Roku 3 automatically.
I have seen previous comments about this problem but have never found a solution.
I would be grateful if somebody could help me. I can only assume it is a Roku software problem as the app used to work without problem.

Labels (2)
0 Kudos
4 Replies

Re: Roku App - no devices

Hi,

I spent way too much time fooling around with this and am ashamed to admit how long it took me, so I thought I would share my findings to save someone else the grief of messing with this.

Roku Hardware: Roku 2 XS
Devices: PC - Windows 10 Home, Android
Router: Cisco E3000 using wireless connection

I got the infamous "No Devices Found" when trying to connect the Roku App from Windows 10 computer (installed from the Windows 10 "App Store"). Then after reading several "solutions" through google, and nothing worked for me, so I tried my android device. My android device had used this app many times, but I had not used it in many months, so I thought I would give it a try and found that it was having the same problem, so I knew it was not a device issue, and suspected a network issue.

Tried to fool with McAfee network security thinking that it was "trying to do me a favor by protecting myself", since I had installed it recently, but this did not seem to help with anything, so that wasn't it.

Found that the IP address listed in the Roku Settings / Network was listed in my DHCP client list of my rounter, and did not make any changes with in the router settings.

uninstalled and reinstalled android device, but did not help.

Tried the PING command and when I pinged the IP address given by the Roku, I got the message "Destination host unreachable". Hmmm.... Seems like a network issue. Now keep in mind that I had no problems watching channels through Roku, so it was connecting and displaying video just fine. I also noticed that the IP address that was returned from the PING command was different that the IP address that I pinged in the first place, so something in the network seemed confused.

I went into Roku network settings and tried to refresh the connection, but this did not help. Then I took it a step further and cleared the password and actually reacquired the signal by selecting the router and re-entering the password to get a new connections. Now this ended up giving me the same IP address when connected, so I am not sure if it really helped in the final solution.

Solution:
Finally, the last thing I did that seemed to do the trick was to actually reboot my router (actually, I also changed the max number of IP addresses from 150 to 151 and saved the settings, then did the router reboot).

After that, I tried my android device again, and it actually found the device! Then I tried the Windows 10 PC app again, and it also found the device! Its all working now for both devices. It had been a very long time since rebooting my router and I probably had changed some IP addressed around on unrelated things at some point over time, so something must have confused something somewhere.

Anyway, it works now , so the take away from this experience is to at least try two things:
1) Ping the IP address of the Roku and see if it is successfull, and note the IP address it comes back with.
2) Reboot router
3) Maybe reacquire and re-enter the WIFI password on the Roku (but I am not sure if that helped or not)

I hope this helps,

John
0 Kudos

Re: Roku App - no devices

After reading this post that I submitted, I thought I would add something else that might help. My local IP address was 192.168.1.xxx, so don't worry about that B.S. that you might have read about the (suspected) requirement to have an IP address with 192.168.0.xxx, as it did not matter in my case.

Thanks,

John
0 Kudos
kapaskae
Level 7

Re: Roku App - no devices

I created an account to give my solution since even in 2018 I was having the same problem. Short n' sweet:
Your network is to blame. Go to your computer and type in your networks IP address into your internet's search bar. (I believe you can just type ping into command prompt but don't quote me) you router splash page or login page should appear after pressing enter. Login, you may need to Google the default login for your router or ask your isp. After logging in head on over to your WiFi settings, in my case (Arris router) it was gateway>connection>wifi. Here you will see your available wifi connections. In my case a 2.4g and 5.0g. I know for a fact (and you should check as well) that both my Roku and device are connected to the same wifi. Anyways, click edit on your WiFi, whichever one you are using, and search the page for a setting called one of the following "edit, security mode, security". Click that, once you get there you should see options to change the security mode, the options should include WPA2. mine was set to default at WPA2, the way if ixed the issue was changing it from wpa2 only, to WPAWPA2-PSK (TKIP/AES). Then click save. You should need to reconnect your phone/Roku to the wifi. Same password.

This worked for me but your mileage might be different. If it does work, go back in and change the setting back to what it was originally set to. Just in case another one of your devices doesn't play nice.
0 Kudos
Dan_Goodrick
Level 7

Re: Roku App - no devices

I was getting this error I have while being connected to one (2.4ghz) of my two Wi-Fi networks. I switched to the 5g network and connected immediately
0 Kudos