Roku Mobile App

Help with the Roku Mobile app on Android and iOS, adding channels, using remote control functionality, playing content from The Roku Channel, using Play on Roku, mobile private listening, and more.
cancel
Showing results for 
Search instead for 
Did you mean: 
LoneWolffe
Level 7

Android Private Listening drops when phone sleeps

Devices
Roku Express Model 3700X
S/N YU009R221444
V7.6.0 b4120-28

Google Nexus 6P

Netgear N600 WiFi router
WiFi signal "Excellent" Channel 6

Channel
Netflix v4.2 b75021003
Radio Paradise v2.6 b1

Problem
Using Private Listening​ via Android smartphone, audio quality and stability and sync are all great, but only as long as the screen is on. If I let the screen time out, audio starts skipping, resyncing, and sometimes drops completely. Once I turn the screen back on, everything works perfectly again. It doesn't make a difference what channel I'm listening to.

In Netflix, enabling Private Listening also screws up the subtitles. They go faster and get all out of sync.

Thank you for your help.
"There's no such thing as a foolproof system. Someone will make a better fool, tomorrow." @LoneWolffe
0 Kudos
7 Replies
lion7718
Level 8

Re: Android Private Listening drops when phone sleeps

In your phone settings...Settings/Wi-Fi...click the gear icon...Keep Wi-Fi on during sleep...Always.

This is from my Nexus 5X, should be the same path as yours.
Roku Stick: 3800RW
Roku Stick: 3800X
Roku Stick: 3600X (Died)
Roku 1 SE: 2710X (Retired)
Roku 2 XS: 3100X (Retired)
0 Kudos
Elijah_Baley
Level 8

Re: Android Private Listening drops when phone sleeps

Maybe it is even more simple than that. Listen to more exciting music so your phone does not get bored and go to sleep in the first place. Maybe a little "Aerosmith" or "Black Sabbath" or "Guns N' Roses' " or "Iron Butterfly" or some other slightly hard rock selection would keep your phone's interest peaked.

If that does not work try going back to "Led Zeppelin" or "Metallica."  Those always seem to perk me right up even after a 48 hour programming session where I had to work in COBOL.
Two Roku Ultras, three Roku 3s and a Roku 1
"Part of the secret of success in life is to eat what you like and let the food fight it out inside." Mark Twain
Van Roy's Law: An unbreakable toy is useful for breaking other toys.
0 Kudos
LoneWolffe
Level 7

Re: Android Private Listening drops when phone sleeps

"lion7718" wrote:
In your phone settings...Settings/Wi-Fi...click the gear icon...Keep Wi-Fi on during sleep...Always.

This is from my Nexus 5X, should be the same path as yours.

Actually, that was the first thing I checked, and it's set as described. =/
"There's no such thing as a foolproof system. Someone will make a better fool, tomorrow." @LoneWolffe
0 Kudos
kakasi08
Level 7

Re: Android Private Listening drops when phone sleeps

i'll try this settings. Thanks for sharing the information...
0 Kudos
whitenack
Level 7

Re: Android Private Listening drops when phone sleeps

Was a fix ever found for this?  I am having the same trouble with my TCL Roku TV.  

I thought it was probably my battery optimization settings, but I changed those and the problem still continues.
0 Kudos
LoneWolffe
Level 7

Re: Android Private Listening drops when phone sleeps

"whitenack" wrote:
Was a fix ever found for this?  I am having the same trouble with my TCL Roku TV.  

I thought it was probably my battery optimization settings, but I changed those and the problem still continues.

=/ no change. honestly, i gave up and ran a long headphone extension from the back of my TV.
"There's no such thing as a foolproof system. Someone will make a better fool, tomorrow." @LoneWolffe
0 Kudos
786tech
Level 7

Re: Android Private Listening drops when phone sleeps

Same issue for me on Samsung Galaxy S8
0 Kudos