Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
egnoriega
Level 7

Using Roku TV, closed captioning keeps turning "always on" on when set to "on mute" after mute.

I'm using a TCL version of Roku TV. I noticed after the latest update, the antenna TV app be much slower, but more troublesome that the closed captioning is no longer easy to manage. Usually it's set to "on mute", but now it is constantly flipping back to "always on." I wasn't sure if there was some Global setting that could be tweaked?

4 REPLIES 4\
SharonS
Level 9

Re: Using Roku TV, closed captioning keeps turning "always on" on when set to "on mut

 Closed captioning on my TCL Roku TV has a mind of its own, too. The problem started after the upgrade that changed the look of the Options menu. I'll change the caption to On mute or On replay, and it'll switch itself back to Off or On always. Sometimes after 6 or 7 tries I'll get my setting, but usually I just give up 😑. I updated the system on Dec. 12, 2020, but the problem persists. 

Tags (1)
rome_411
Level 7

Re: Using Roku TV, closed captioning keeps turning "always on" on when set to "on mut

Roku, please fix this problem. I’ve seen comments on other similar posts indicated that it is a specific app. This makes no sense as why would one app override your entire system settings. I have two Roku Smart TVs and a Roku box. The problem exists no matter which app is used. The simple turning on the device seems to trigger captions always on. Perhaps you can create a captions always off instead of just captions so we aren’t inconvenienced with turning them off everytime we access the first app for the day. One the initial change is made to take the captions off, they remain off for the entire session on all apps, but reappear once the system is turned off and back on. Not a good product experience.

crowda
Level 7

Re: Using Roku TV, closed captioning keeps turning "always on" on when set to "on mut

Can confirm that I just figured out the issue I was having with closed captioning had to do with HBO Max applying its own setting to the entire system. I finally stopped the captions from turning themselves on all the time by opening the web player at play.hbomax.com, opening a stream, and turning off captions. But that is hardly a solution as this shouldn't be happening in the first place, and I am now stuck with "off" as my system setting for the foreseeable future when I preferred "on replay" or "on mute."

Roku Team, for the love of god, please fix.

Side note if a developer ever reads this, sure would be nice if we could select multiple because I would really like my setting to be on replay and on mute, but not on always.

 

renojim
Community Streaming Expert

Re: Using Roku TV, closed captioning keeps turning "always on" on when set to "on mut

@crowda, this would be a good thing for Suggest a Feature | Roku Community | Roku .

Roku Community Streaming Expert

Help others find this answer and click "Accept as Solution."
If you appreciate my answer, maybe give me a Kudo.

I am not a Roku employee.
0 Kudos