Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Search instead for 
Did you mean: 
guitarboy
Level 9

Screen Mirroring Android Phone Has Stopped Working

The first couple of times I tried screen mirroring from my Samsung Galaxy S7 Edge to my Ultra 4660X it worked like a charm.  But now, the phone connects to the Roku and the screen displays the message "Starting video from..." for a few seconds.  Then the connection drops and the Roku returns to the home screen.  I've scoured the Web looking for a fix.  A lot of people are complaining about casting/mirroring problems and some are even offering solutions that involve rooting the phone (which I'm not about to do). I've checked this forum but haven't found anything that's identical to my situation.

To set up screen mirroring, I followed the instructions in this article.  I used Smart View on the S7 and selected the Roku as the target device.  As I mentioned, this was working but now can't get past the initial load screen.

Is anyone else running into this problem?

The Ultra is brand new and running the latest build of OS9.

_____________________________
Roku Ultra 4640X
Labels (1)
0 Kudos
2 Replies
Community Manager
Community Manager

Re: Screen Mirroring Android Phone Has Stopped Working

Thanks for the note here. 

Have you tried restarting your phone, the Roku and your wireless router simultaneously, then trying to connect again? When did you first observe the failure beginning? 

Please PM me with your Roku account email address, the serial number of your Roku Ultra from Settings>System>About, along with the specific version/build of Android that your device is running. We'll take a closer look to see how else we can assist. 

Thanks,
Tanner
Tanner D.
Roku Community Manager
0 Kudos
guitarboy
Level 9

Re: Screen Mirroring Android Phone Has Stopped Working

Have you tried restarting your phone, the Roku and your wireless router simultaneously, then trying to connect again? 


I tried this (rebooted all 3 simultaneously), and it's working again!  Fingers crossed that it stays that way.  I had previously separately rebooted the phone and the Roku, so maybe it's just the router that's at fault.
Thanks for the suggestion.  If it happens again I'll pass on the info you requested.
_____________________________
Roku Ultra 4640X
0 Kudos