Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sogrady
Level 8

Roku OS 10.0 Update Breaks Surround Sound

I have a Roku Ultra patched into a 5.1 setup via an Onkyo receiver (TX-NR626). Up until this week, I had no issues getting 5.1 sound on media that supported it. Two days ago, on the 22nd, I resumed play of a title encoded in non-surround sound (Stereo AC3) and the audio was just pops and clicks.

After a lengthy debugging process between services and devices, the fix was to switch the Roku to Auto-detect in Settings:Audio:HDMI from Dolby Digital / DTS. All of a sudden, that video played just fine and all was well. I do not have an Auto-passthrough option, for those who might recommend it.

Anyway, what I hadn't noticed was that Auto-detect, as far I can tell, does not work. Videos play, but surround does not work. All 5.1 audio regardless of formatting is now processed by the receiver as PCM stereo output. And if I try to manually set the HDMI output to any one of several of the formats supported by my receiver, the pops and clicks return.

None of the audio, as mentioned above, had any issues previously being processed as surround sound content.

Given that I had not made any other changes to the system, and the fact that the initial error was fixed by changing the settings of the Roku, I looked there first. And indeed, according to the Roku itself, it was updated to version 10.0 build 4177 on the afternoon of April 21 - the afternoon before my issue first appeared.

So I downgraded to 9.4.0 build 4210 and the issue is gone. Surround plays as normal, no issues. Only problem is that I'll be reverted back to 10.0 tomorrow, and have to do this all over again. 

Hoping someone from Roku sees this thread and can get it back to the engineers. 

74 Replies
RokuDanny-R
Roku Employee
Roku Employee

Re: Roku OS 10.0 Update Breaks Surround Sound

@sogrady

Thanks for the post.

We would be happy to look into this issue for you. Can you please provide us the following information:
-Roku device model
-serial number
-device ID
-software OS/version
(these can all be found in Settings > System > About)
-does this issue occur on a specific channel? if so, what channel and what version/build is the channel (this can be found be selecting the channel on the Home screen and pressing the * button)
-tracker ID when this issue occurs (when you see this issue occur, press the Home button 5 times, followed by the Back button 5 times)
-steps to reproduce the issue you are seeing

-what is your audio set to (let us know what is shown in Settings > Audio > HDMI)

 

Once we have this information we will be able to investigate further.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
sogrady
Level 8

Re: Roku OS 10.0 Update Breaks Surround Sound

Hi @RokuDanny-R

Thanks for the reply. Answers are below. Any other questions, let me know. 

-Roku device model: 4670X - Roku Ultra
-serial number: YJ008T426327
-device ID: KWA088426327
-software OS/version: current, which works, is 9.4.0 - build 4210-46. problem is with 10.0 build 4177
-does this issue occur on a specific channel? if so, what channel and what version/build is the channel? 
I first noticed it on Plex, multiple versions (preview and regular builds), but it appears to be the same for Disney+, Netflix, etc.
-tracker ID when this issue occurs 
I'd rather not reinstall 10.0 because I have no guarantee I'll be able to revert to my current, older working build so I can't supply this.

-steps to reproduce the issue you are seeing
Immediately after upgrade (with audio still set as indicated below), play movie with audio encoded as:

Stereo AC3
5.1 AC3
(possibly others, didn't test any more after the OS reversion fixed things)

Nothing but loud pops and clicks.

The following formats did not experience an issue and played fine:

5.1 DTS
5.1 EAC3
Mono DTS
Mono AAC
Stereo FLAC

To resolve the issue, switched the audio away from the specific settings below to autodetect. This eliminated the pops and clicks, but the auto-detect did not work and everything was rendered as PCM stereo audio regardless of formatting.

-what is your audio set to
Audio mode (Auto(DD, DTS))
HDMI (Dolby Digital, DTS)

0 Kudos
RokuDanny-R
Roku Employee
Roku Employee

Re: Roku OS 10.0 Update Breaks Surround Sound

@sogrady

Thanks for the follow up and providing us with your information.

I have passed along the information to the appropriate Roku team to investigate further.


Thanks,
Danny

Danny R.
Roku Forum Moderator
0 Kudos
sogrady
Level 8

Re: Roku OS 10.0 Update Breaks Surround Sound

Thanks @RokuDanny-R.

While they look at the problem, is there any way to temporarily prevent an automated update to the new OS? I'd prefer to not have to manually downgrade it again, assuming that remains possible. 

0 Kudos
sogrady
Level 8

Re: Roku OS 10.0 Update Breaks Surround Sound

Oh, and one other thing @RokuDanny-R, in case it's of use apparently other people are experiencing the same issue. See the comment here

Duxa
Level 8

Update 10 broke Dolby Digital playback

Today's update 10.0 broke Dolby Digital playback on my Roku 4. DTS still works fine, stereo does too. But trying to play Dolby Digital content (5.1) results in loud popping and clicking. When looking at the signal coming from Roku it seems like it does not match DD signature. Please roll back firmware or release a fix ASAP. Impossible to watch anything that is encoded with Dolby Digital (AC3 etc).

Duxa
Level 8

Re: Roku OS 10.0 Update Breaks Surround Sound

Same situation here on Roku 4 after receiving the 10.0 update today. Anything and everything with Dolby Digital 5.1 produces loud pops and clicks. DTS and Stereo continue to work. I hope Roku can roll back to previous firmware version or push a fix fast. 

@sogrady how did you downgrade? I wish to do so even if it means doing it every day, because we were going to have a movie night with the kids today but having to watch a movie in Stereo pretty much canceled the movie night Smiley Sad

 

-Roku device model: Roku 4
-serial number: YY0020011508
-device ID: 4U7592011508
-software OS/version: 10.0
-does this issue occur on a specific channel? Any channel that outputs 5.1 Dolby Digital (DTS and Stereo work fine).
-tracker ID when this issue occurs (when you see this issue occur, press the Home button 5 times, followed by the Back button 5 times): 08-170-339
-steps to reproduce the issue you are seeing: Just trying to watch anything with Dolby Digital 5.1 Audio

-what is your audio set to (let us know what is shown in Settings > Audio > HDMI): Dolby Digital/DTS, like I said DTS works fine, DD does not. This setup has worked flawlessly for many years. 10.0 is what broke it. if I set it to "Auto" it just plays everything in stereo. 

 

sogrady
Level 8

Re: Roku OS 10.0 Update Breaks Surround Sound

@Duxa 

I used the instructions here to downgrade. 

0 Kudos
andyross
Level 16

Re: Roku OS 10.0 Update Breaks Surround Sound

I have a Roku 4 and an Onkyo TX-NR696. I just did a test with Netflix, and it's getting DD+ 5.1 with no problems. The Roku is directly connected to the Onkyo.

0 Kudos