Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7

Roku 3 (4230x) Wiped Out After 9.3.0 (4170) Update

My Roku has performed flawlessly for years - zero problems. The Roku is wired to my network, not wireless. I use my Roku 3 to drive my media room projection setup. The HDMI output goes from the Roku to a HDMI-to-component breakout box - audio goes to my amplifier and component cables to my projector. It's a 1080P setup that has worked great... 'til now.

After the 9.3.0 update... I started getting "no signal". I went about triple-checking every individual component and found no problems. I changed every cable to new spares - again, no problems. Whole house surge protector and pure sine wave system to ensure clean power to the rack where the Roku's installed - no a power problem.

If I plug the Roku 3 directly into an TV there's an HDMI handshake and it works - tried directly connecting it to several TVs - all worked. I've tried a complete factory reset of the Roku and made sure it worked fine plugged into a TV. Then I installed it back into my media room and it WORKED... for two days. Then it went back to "no signal".

Since this happened when the firmware auto-updated to 9.3.0 it looks like the new version doesn't like my legacy set-up. I don't know if it's one of those infamous HDCP issues or not, but I'm certainly not tossing my equipment to make Roku happy. I would like to roll back to the older firmware - I was perfectly happy the way things were - no option I can see there.

What am I missing?... any ideas.

 

 

Tags (3)
0 Kudos