Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Search instead for 
Did you mean: 
hd_harry
Level 7

Possible Software Version 8.0.1 Issue

I have a Roku Express+ Model 3910RW that I connect to a Hitachi rear projection TV. The TV is old enough that it has component video inputs but no HDMI inputs. Thus, I use an HDMI to component converter between the Roku and the TV. I normally also have an HDMI switch located upstream of the converter so that I can switch among a cable box, a Raspberry Pi running Kodi and the Roku. This setup has been working fine for me since the first of the year. The Roku shows a display type of 720p, HDCP 1.4.

Starting this past Tuesday, March 27th, the Roku has been displaying a purple screen and the message "HDCP Unauthorized." For troubleshooting purposes, I removed the HDMI switch and connected the Roku directly to the HDMI to component converter, and I still get the purple screen. I've checked various streaming sources (e.g., YouTube and the Roku Channel), and they all display the purple screen.

I checked the Roku settings and noticed that my device was updated to Software Version 8.0.1, build 4090-51 on the late evening of March 26th. Since the Roku was working for me on March 26th before the update but it isn't since the update, I suspect that the problem might be related to the update.

I connected the Roku to my PC monitor through its HDMI port, and it works just fine for that with the same display type of 720p, HDCP 1.4. Likewise, if I connect the Roku directly to my TV using the Roku's A/V output jack and the TV's composite input, that also works, although at a lower resolution than I get with the HDMI/component connection.

For now I'm running my cable box and Raspberry Pi through the HDMI switch and HDMI to component converter connected to a component input source on the TV and the Roku through a composite input source on the TV.

I assume there is no way to revert to the previous version of the Roku software to see if the upgrade is the problem. If anyone can think of something else I can try, I would appreciate it.
0 Kudos
5 Replies
ghb51
Level 9

Re: Possible Software Version 8.0.1 Issue

I have no idea if this will work for you, but, I have a 2005 Samsung connected to Roku with a HDMI to DVI adapter and it frequently has problems with HDCP, what usually works for me is to unplug the Roku and Samsung for a few minutes, then plug the Samsung back in and connect a device I know is HDCP compliant into the same input I use for the Roku, if it works, the Roku will usually work once reconnected, if it doesn't I just repeat the process until it does work, it's never taken more than three tries. As to what's causing it, who knows, the tv's are old and HDCP is poorly implemented in general, no telling where the fault lies.
0 Kudos
hd_harry
Level 7

Re: Possible Software Version 8.0.1 Issue

ghb51,

Thanks for the suggestion. I gave it a try, but no go.

I guess I'll just have to live with the lower resolution that goes with a composite video connection.
0 Kudos
Matt9876
Level 7

Re: Possible Software Version 8.0.1 Issue

My Roku 3 and my brand new Dell monitor HDCP 1.4 spend most of it's time in a purple screen mode, It looks like YouTube is sending out the purple screens because the bottom row of icons show through while the main area is purple with the HDCP unauthorized message is displayed.

All I know is when the commercials, 8 bit computer shows and my own videos are purple screen locked in 1080p mode someone is over reaching for money / control over what you can and can't watch on streaming video.
ROKU Premiere Plus
ROKU 4
ROKU 3
Tablo OTA DVR
Samsung 4K UHD TV
Hisense 4K TV
0 Kudos
dansoftn
Level 7

Re: Possible Software Version 8.0.1 Issue

With a Roku 1 and a 4:3 television tv and desiring to set to 16:9 composite try this:  Set to 4:3 composite, say yes;
set to 16:9 composite, say yes;
set to 4:3, say yes;
set to 4:3; say no! 
And now the setting reflects 4:3 but if you login to MLB.tv and watch live you will see a 16:9 format.  Setting to 16:9 has had no effect lately.

I have tried a factory reset.
I have tried a restart.
I have tried a power cycle.
:x :x Smiley Wink
0 Kudos
etedj
Level 7

Re: Possible Software Version 8.0.1 Issue

I am seeing the same issue on my Roku. I have a Roku Premiere+, attached to a projector through an AVR. Ever since the 8.0.1 update on Mar 27 I am getting the purple HDCP error. I've tried unplugging everything, swapping cords, changing my screen resolution to 720p... nothing fixes the issue. 

Everything had been working for over a year until the latest update. 

I've escalated the issue with Roku support. Hopefully the Roku devs can fix the issue and put out a patch soon Smiley Happy
0 Kudos