Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Jon_W
Level 7

Re: [Official] Roku OS 8.2

To RokuShaunS,
Can you please post a status update on what is being done and when these OS 8.2 issues will be resolved??? My 4K TV was unable to function throughout all of the holidays and football bowl season.  This is really frustrating.
0 Kudos
RowkooJim
Level 7

Re: [Official] Roku OS 8.2

My tv on 8.2 is still not streaming sling or Hulu.  Weird enough it will stream YouTube just fine most times but the vast majority of my tv watching is via the other 2 apps.  However I am back to using my old roku 2 that used to be on OS 8.1 and worked flawlessly if a bit slow due to the processor.  But it was doable.   That roku updated itself to OS 9.0 a few weeks ago which concerned me very much at first because I was leaving it unplugged when not being used so it wouldn't update to 8.2 and become a brick too.   But it caught me one day and updated.  But it updated to OS 9.0 and lucky for me 9.0 seems to stream fine on the old roku 2.  So I'm (Im)patiently waiting for my roku tv to update to 9.0 with the rose colored hope that it will resolve this stupid 8.2 OS that has rendered my tv to being a monitor for the last several months.  

Anyone else on OS 9 now?   Is that working for you?   I know this topic is about a different app or function not working but I've been jumping in and following it because my problem is also 8.2.  
0 Kudos
thomasz
Level 7

Re: [Official] Roku OS 8.2

After not much change for over two months now for 8.2, I have already moved on to hoping Roku OS 9 will resolve the issues and not making anything worse. I started pulling an ethernet cable through my house to connect the TV wired which helps and was considering buying a Fire Stick as backup as some folks on the web suggest as apparently every new release of Roku OS might hit your specific device with issues. So keep hoping on OS 9, which should arrive for the TVs between now and end of March. Keeping fingers crossed.
0 Kudos
JBL
Level 8

Re: [Official] Roku OS 8.2

"Legierk" wrote:
Received 8.2 on my TCL TV tonight. So far, it appears that the DD+, DTS issue has been fixed. I will confirm when I get more sources and formats through it however. Otherwise, everything appears to be the same. I did not have to reset any settings, including picture, so that was a nice touch. I don't really notice any new features, but I wasn't looking either.

Edit: OK. DD+, DTS output from TV is not working properly. In fact, it may be worse. To recreate, connect TV to AVR with HDMI using ARC. Set TV audio out to DD+, DTS. Send any STEREO (two channel) signal (the Pandora music app for example) to the AVR. Set the AVR to output STEREO. What you will hear is what is commonly referred to as the difference signal, or L-R )left minus right). Very odd. The update (8.2) may be worse, because now not only is the signal L-R, but there is a severe "pumping" of the signal. 

Now, in order to fix the problem (so you can listen to Pandora in stereo, for example), just change TV output to DD, DTS. Problem goes away. It is not an HDMI cable issue. It is not a Pandora issue. It is not an AVR issue. The fact that everything works as expected in DD, DTS (no +) mode, tells me its a Roku software implementation issue. Oh well, maybe next update.

I have the same issue on my TCL 55R617  with firmware 8.2.2 hooked up to a 2011 Denon AVR. DD+ works fine from my old 2011 Samsung Plasma and my KM8 Android media player but the Roku produces a low pumping/chirping output in the AVR.
0 Kudos
RokuTannerD
Level 19

Re: [Official] Roku OS 8.2

@JBL 

A few questions here: 

Are you using HDMI audio out from the TV to the receiver? (Note: DD+ is not supported via optical audio out) What channel and content are you observing this issue with? Are you using Roku TV wireless speakers with that TV while attempting playback through a separate receiver? 

Please PM me with these details, and include your Roku account email address. I'll help investigate further and get you in touch with our team for further support, if need. 

Thanks,
Tanner
0 Kudos
ghostintheruins
Level 7

Re: [Official] Roku OS 8.2

Hello, I purchased the TCL 615 on December 16th, and was updated to 8.2.2 4097-30 as soon as I set it up.  I have the set on a wired connection, as opposed to Ethernet.  On at least four occasions, I've had the TV randomly turn off.  It has happened with different apps, so there's not a common theme that I can find.  It will take about 30-60 seconds before it will allow me to turn it back on, and then it will usually shut off again a second time within 10-30 minutes.  It once it turns back on, it returns to the home screen, so it does not seem to be a hard reboot.  I've tried to search for solutions, and came across others having a similar issue.  A post within the link below implies that "Called back and now they're saying it's a software issue and a fix is coming," but I was hoping to find something more official.  I really don't want to return it, but I have six days left to return the set if necessary.  I certainly don't want to be stuck with a set that may power down at random. 
 
https://www.reddit.com/r/Roku/comments/a0jile/tcl_r615_roku_tv_keeps_turning_off_by_itself/
0 Kudos
RokuTannerD
Level 19

Re: [Official] Roku OS 8.2

Thanks for sharing your report here. It's hard to say what might be causing this type of issue. I'd like to gather more information about what you are seeing, and help determine next steps to see if we need to get you in touch with the TV manufacturer for additional help. 

Please PM me with your Roku account email address and the serial number of your TV from Settings>System>About. I'll continue assisting you directly from there. 

Thanks! 
Tanner
0 Kudos
JBL
Level 8

Re: [Official] Roku OS 8.2

"ghostintheruins" wrote:
Hello, I purchased the TCL 615 on December 16th, and was updated to 8.2.2 4097-30 as soon as I set it up.  I have the set on a wired connection, as opposed to Ethernet.  On at least four occasions, I've had the TV randomly turn off.  It has happened with different apps, so there's not a common theme that I can find.  It will take about 30-60 seconds before it will allow me to turn it back on, and then it will usually shut off again a second time within 10-30 minutes.  It once it turns back on, it returns to the home screen, so it does not seem to be a hard reboot.  I've tried to search for solutions, and came across others having a similar issue.  A post within the link below implies that "Called back and now they're saying it's a software issue and a fix is coming," but I was hoping to find something more official.  I really don't want to return it, but I have six days left to return the set if necessary.  I certainly don't want to be stuck with a set that may power down at random. 
 
https://www.reddit.com/r/Roku/comments/a0jile/tcl_r615_roku_tv_keeps_turning_off_by_itself/

I've noticed at least 3 times (in the last 2.5 weeks) when turning on my TCl 55R617-CA (8.2.2 4097-30 firmware) that it would appear to cold boot with the red screen for ~10 seconds, turn to a black screen and then reboot again. 
0 Kudos
Legierk
Level 8

Re: [Official] Roku OS 8.2

"JBL" wrote:

I have the same issue on my TCL 55R617  with firmware 8.2.2 hooked up to a 2011 Denon AVR. DD+ works fine from my old 2011 Samsung Plasma and my KM8 Android media player but the Roku produces a low pumping/chirping output in the AVR.

I have not checked this thread in awhile. I keep my TCL set to plain DD/DTS and it doesn't have issues. Only setting it to DD+ creates the problem. Since there hasn't been an update on mine since November, I haven't checked to see if its fixed. Let me know if you get any resolution.
0 Kudos
Jerrywood45
Level 7

Re: [Official] Roku OS 8.2

Are the new series 6 55 inch TCL Now have OS9
0 Kudos