Roku Device Features, Settings & Updates

Help configuring Roku device settings, using Roku OS features such as screen mirroring, adjusting display type and audio settings, using Guest Mode, and assistance with software updates.
cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
kevinhenry
Level 7

Re: [Official] OS 9 Release Notes

I have Roku Ultra's in all my rooms, I also have fire tv, and apple tv in my main living room. Can confirm that the 9.0 update caused Dolby and surround to not register in my Onkyo and Denon AVR's. Tablo will not play content saying my device does not support surround sound. I have spent a great deal of time trying to determine the problem. 

Fire TV and Apple TV no issues. 

This is a ROKU issue!

Who at ROKU decided to release this Update during the holidays and take a long break? 9.1 better hurry if you want to keep your AVR clients!
0 Kudos
Steven547
Level 7

Re: [Official] OS 9 Release Notes

Unfortunately, the issues with Roku are too big to ignore.  I can no longer connect my Roku using a wired connection and the audio does not register as Dolby (a lot of shows switch to PCM).  I have a Fire TV now and will probably have to retire my Roku.  The audio issue has been going on for a long time and has never been addressed by Roku.
0 Kudos
iFrog
Level 9

Re: [Official] OS 9 Release Notes

"Steven547" wrote:
Unfortunately, the issues with Roku are too big to ignore.  I can no longer connect my Roku using a wired connection and the audio does not register as Dolby (a lot of shows switch to PCM).  I have a Fire TV now and will probably have to retire my Roku.  The audio issue has been going on for a long time and has never been addressed by Roku.

Which issue are you referring to?  In my experience there have been quite a few audio issues Roku has had that have affected different people in various ways.  For me, most have been resolved while a couple are still hit, or miss, such a the reliability of DTS audio playback when it comes to local streaming from Plex, or another / similar solution.  Beyond that, I've had audio delays of various types, that were annoying to deal with, but presently have been resolved  for the most part.  The DTS issue is really my only audio complaint with Roku devices at this point.
Like others here though, I've started using other devices better equipped to handle what Roku has issues with.  So, I use the best device for the task.  For me, Roku is good for internet content, and OK for local streaming while a Shield TV, or blu-ray player with DLNA, or even an Apple TV  with the right App, make that area much easier to work with.
0 Kudos
Doctor_Manhatta
Level 8

Re: [Official] OS 9 Release Notes

I have a 2016 Ultra (4640RW), s.n. YP001H448748, now running 9.0.0 Build 4084-29. Night Mode is now gone. A lot of the programming now comes through with stereo sound, where it used to show as "Digital" on my Sony AVR. Once in a while, something does still come through with DD+ or even DTS, but generally, it's just stereo. There are no new sound options on the Roku...just lost former options. I've had this unit for almost a year now. After about three weeks, it replaced the original 4640 that I got from Amazon for Christmas in 2017 when that unit continually locked up and/or lost connection with WiFi and/or its own remote. When I returned it to Amazon, they replaced it with this unit...also new, but of slightly older spec. With this unit, WiFi was still flighty...but I eliminated that problem with a powerline/Ethernet setup that has been rock solid ever since. The remote connection has continued to be an occasional headache, though I can't swear that it has happened since the OS "upgrade". Everything has been tried with the remote. The only thing that works is popping a battery out and back in...the pairing button inside the remote has never done anything. This solution is made even more irritating by the fact that the battery cover on the remote is kind of a project to remove.

I believe my Roku has been made more reliable by plugging its wall cube into a switched outlet, and then turning it off whenever it's not being used. In this way, it's operating on a fresh boot every time it's used. I haven't witnessed a single lock-up since I've been doing this, where the original unit locked up quite often if it was left it "hot". 
0 Kudos
jsmiddleton4
Level 7

Re: [Official] OS 9 Release Notes

Noticed the stereo audio myself.  Used to be mutli channel.  Roku did their usual FW coding, 2 steps forward, 3 back.
0 Kudos
iFrog
Level 9

Re: [Official] OS 9 Release Notes

I was curious if there was something in common with the people experiencing the loss of multi-channel audio here.  I have 2 Roku players in use:

2016 Premiere+
2017 Ultra

both running the latest build of OS 9, and all my usual sources of multi-channel audio still work.

I use sound bars with wireless rear speakers and subs, vs wired AVRs for space and layout reasons, however the the codec support is the same other then ATMOS, or lossless codec support, but they do PCM multi-channel, so that's an easy work around to have supported devices internally decode and send as PCM 5.1.

With that said, when it comes to the Roku, all natively support is there Dolby Digital 5.1, DTS 5.1, Dolby Digital Plus 5.1.
I have my 1080p setup directly connected by HDMI via a switch for all devices, so the Roku has access to all supported codecs.  The Living Room setup is a mix of HDMI versions so I have the Roku connected to the TV by HDMI , and the sound bar connected to the TV via optical.  My X700 UHD disc player has dual HDMI outs so it has direct HDMI connections to both devices.

Either way, Netflix, Plex, and other supported sources still give me multi-channel audio on both setups.  The main difference is, the 4K setup for Roku has the DD+ converted to standard DD 5.1 through the TV simply because of the way it's connected, but DTS, and standard DD, are directly passed.  The other setup passes everything direct over HDMI since it's all the same HDMI spec.

As mentioned, my Premiere+ did lose the night listening mode with the OS 9 upgrade, and the 2017 Ultra retained it, however neither unit has suffered any of the other audio issues people are reporting here.  So that's why I asked if there was maybe something in common with those experiencing the issues.
0 Kudos
dwgsp
Level 7

Re: [Official] OS 9 Release Notes

My 4200X is also having audio issues with software version 9.0.0 build 4084 which was installed on December 12.  Also, a Display Type issue that was occurring earlier this year has returned.  Both issue seem to be related to an HDCP detection issue in the Roku firmware.

My 4200X is connected via HDMI to a Yamaha RX-V573 AVR, which then feeds video via HDMI to a older Sony HDTV.  I also have a Tablo DVR, which is configured to record in surround sound mode.  The entire system is controlled by a Harmony remote.  The Roku is powered on 24/7.

Starting with Build 4084, when we use the Harmony to turn on the system the Roku sometimes displays an HDCP error message for a few seconds, then it changes it's Audio configuration to Stereo (it should have detected Dolby D+, DTS) and Display Type to 480p (it should have detected 1080p).  This seems to be occurring at least 75% of the time.   If we then reboot only the Roku, it then boots up and correctly detects the Audio and Display Type.

This is a serious problem, because all of our Tablo recordings are in Surround mode, not Stereo, and the Tablo won't play them on a Roku that is in Stereo mode.  So we cannot watch any of our recordings after this error occurs.  The only workaround is to reboot the Roku, which is a pain.  My wife is the primary television watcher in our family, and to say that she is getting ***really*** annoyed is an understatement.

We had a similar Display Type problem on the Roku earlier this year.  At that time I contacted Roku technical support, who never admitted that there was a firmware issue and eventually they closed my ticket with no resolution.  That issue went away a few months ago, after a new firmware build was pushed to the Roku.  That problem was a bit different than what we are seeing now, because it did not happen as frequently and no HDCP error was displayed.  At that time, the Tablo only supported Stereo so we would not have noticed if the Audio mode was also affected.  My wife does not care if the Display is in 480p mode, so previously she usually just lived with the issue.  Now it's a much bigger deal.

I will be happy to help the Roku team in any possible way to address this issue.  Maybe they just need to apply the same fix as what was done before.  I'm willing to beta test the fix if that is helpful.
0 Kudos
fonzy35
Level 9

Re: [Official] OS 9 Release Notes

"Crow550" wrote:
I think you'll need to wait till after the Holidays. Most people at Roku are on vacation. 

Why they decided now to drop OS9 before the Holidays was a bad idea. 

It sure was a bad idea, to many bugs fix needed.. They release it, so we could bring up the bug , so they can fix it. But they should had wait after the holidays, a lot of roku tv, roku device has been sold during the holidays, and everyone in debug waiting mode...lol
0 Kudos
wildsprite
Level 10

Re: [Official] OS 9 Release Notes

"fonzy35" wrote:
It sure was a bad idea, to many bugs fix needed.. They release it, so we could bring up the bug , so they can fix it. But they should had wait after the holidays, a lot of roku tv, roku device has been sold during the holidays, and everyone in debug waiting mode...lol

I just hope they wake up and realize releasing a major OS update during holiday season is a bad idea before it bites them
0 Kudos
Doctor_Manhatta
Level 8

Re: [Official] OS 9 Release Notes

"iFrog" wrote:
I was curious if there was something in common with the people experiencing the loss of multi-channel audio here...

I just went into my 4640's audio settings for the first time since the OS upgrade. Audio was set to "Auto". I changed it to "DD+/DTS", but I haven't run anything through the AVR yet so I don't know whether or not this fixed my problem.
0 Kudos